apt-get update falied

Briefly describe your issue below:
i cant update or install any packages

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64) parrot

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental) debian standard

Configured to multiboot with other systems? (yes / no) no

If there are any similar issues or solutions, link to them below:
i cant update or install any packages

If there are any error messages or relevant logs, post them below:

Hi, thanks for contacting us. Please, give us more details
if you have terminal output or anything that can give us more informations about your problems.

oops, sorry, i thought i had pasted the terminal output.

$sudo apt-get upgrade

i executed the above apt-get (after clean & upgrade) and the following error was returned:

apt upgrade is unsafe on rolling release distributions.

using apt full upgrade instead
use apt upgrade --force to override

The following information may help to resolve the situation:

The following packages have unmet dependencies:
libc6-dev : Breaks: libgcc-9-dev (< 9.3.0-5~) but 9.2.1-22 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

i didn’t see the “apt-get” suggestions originally as the text rolled past in the terminal, just the unmet dependencies error.

is the full-upgrade the way to go at this point with a rolling release or use “–force” option?


I think ,you should run sudo apt-get update.and then you should run sudo apt-get upgrade.

Have you tried?

sudo apt clean;
sudo dpkg --configure -a;
sudo apt install -f;

Also remember always to use
sudo parrot-upgrade for upgrading your system
Read full documentation here:https://docs.parrotlinux.org/faq/#how-do-i-upgrade-my-system


first run sudo apt install gcc-9-base libgcc-9-dev libc6-dev then sudo parrot-upgrade
hope this fixes you problem


thanks for reply…

i did execute:
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade

the error occurred with the last, “sudo apt-get upgrade”.

the first command line i issued was “sudo apt-get clean”.
but no, i did not try the other commands you listed.
i will try those and read the doc at the link you provided.

thank you for the help and educational link you provided!

thank you. i ran that and all the other suggestions.

OS got updated.

appreciate all the help and that link to the docs as i needed that education.

good weekend to all


WARNING: do not use apt-get on rolling based Linux (Parrot)

Use apt command for upgrades, or sudo parrot-upgrade (a script for automating a safer upgrade) as @solo.nepal mentioned (while passing along a link to documentation).

To quote directly from documentation:

First please, do NOT use apt-get upgrade . Because ParrotOS is a rolling distribution and how APT works, the command will cause considerable problems to your system. We don’t recommend apt-get in general as the command is not really meant for end-users.

I hope everything has worked out and that you can avoid potential problems by skipping apt-get usage next time around :slight_smile:


Agree and confirm what was said above.
Please, use sudo parrot-upgrade when you want to upgrade your installation, it automatically launches an apt update and an apt full-upgrade.

Why apt-get is not meant for end users?
apt was created for providing a more way simple mode to manage packages, and don’t make users lost in a lot of commands. So it’s quite simple and easy to use.
it’s more way organized, and shows useful informations for user, such as progress bar while installing/uninstalling and the amount of packages that can be upgraded when you update the repos.

Useful resources which you may be interesting for you:


yes, everything worked out, thanks to the good help. i will indeed skip “apt-get” from now on with ParrotOS.


thank you, i had no idea of their diff until now. now, i have the links bookmarked for study.


Happy to hear that :smiley:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.