Cannot complete GVM install due to missing OpenVAS library

Hi

I have problem after install GVM on a new Parrot Linux 5 install on a bare metal pc. After the main distro install and upgrade I run ‘sudo gvm-setup’ to set up after install system.
All system is updated as always. A Postgres SQL database, admin user and randomly generated password were created correctly.

Then after that process I run ‘sudo gvm-check-setup’ to check if anything is missing but I get the following message:

> gvm-check-setup 21.4.3
> Test completeness and readiness of GVM-21.4.3
> Step 1: Checking OpenVAS (Scanner)…
> ERROR: No OpenVAS Scanner found.
> FIX: Please install OpenVAS Scanner.
*> *
> ERROR: Your GVM-21.4.3 installation is not yet complete!
*> *
> Please follow the instructions marked with FIX above and run this
> script again.

However ‘openvas-scanner’ is installed however when I attempt to check the version or run it, it tells me the following:

> openvassd: error while loading shared libraries: libopenvas_nasl.so.21: cannot open shared object file: No such file or directory`

Where can I get this missing library and where must it be placed?

I have had the same issue in Parrot. Hoping it will be fixed eventually… it is a pain to get working. Here’s the best recent tutorial I’ve used in Kali to get GVM working.

You may want to briefly add the Kali repo to download the working GVM packages after removing what you currently have installed, until the Parrot devs fix things.

└─$ sudo gvm-check-setup
[sudo] password for masmer: 
gvm-check-setup 21.4.3
  Test completeness and readiness of GVM-21.4.3
Step 1: Checking OpenVAS (Scanner)... 
        OK: OpenVAS Scanner is present in version 21.4.4.
        OK: Server CA Certificate is present as /var/lib/gvm/CA/servercert.pem.
Checking permissions of /var/lib/openvas/gnupg/*
        OK: _gvm owns all files in /var/lib/openvas/gnupg
        OK: redis-server is present.
        OK: scanner (db_address setting) is configured properly using the redis-server socket: /run/redis-openvas/redis.sock
        OK: redis-server is running and listening on socket: /run/redis-openvas/redis.sock.
        OK: redis-server configuration is OK and redis-server is running.
        OK: _gvm owns all files in /var/lib/openvas/plugins
        OK: NVT collection in /var/lib/openvas/plugins contains 96310 NVTs.
Checking that the obsolete redis database has been removed
Could not connect to Redis at /var/run/redis-openvas/redis-server.sock: No such file or directory
        OK: No old Redis DB
        OK: ospd-OpenVAS is present in version 21.4.4.
Step 2: Checking GVMD Manager ... 
        OK: GVM Manager (gvmd) is present in version 21.4.5.
Step 3: Checking Certificates ... 
        OK: GVM client certificate is valid and present as /var/lib/gvm/CA/clientcert.pem.
        OK: Your GVM certificate infrastructure passed validation.
Step 4: Checking data ... 
        OK: SCAP data found in /var/lib/gvm/scap-data.
        OK: CERT data found in /var/lib/gvm/cert-data.
Step 5: Checking Postgresql DB and user ... 
        Starting postgresql service
        OK: Postgresql version and default port are OK.
 gvmd      | _gvm     | UTF8     | en_US.UTF-8 | en_US.UTF-8 | 
        OK: At least one user exists.
Step 6: Checking Greenbone Security Assistant (GSA) ... 
Oops, secure memory pool already initialized
        OK: Greenbone Security Assistant is present in version 21.4.4.
Step 7: Checking if GVM services are up and running ... 
        Starting ospd-openvas service
        Waiting for ospd-openvas service
        OK: ospd-openvas service is active.
        Starting gvmd service
        Waiting for gvmd service
        OK: gvmd service is active.
        Starting gsad service
        Waiting for gsad service
        OK: gsad service is active.
Step 8: Checking few other requirements...
        OK: nmap is present in version 21.4.4.
        OK: ssh-keygen found, LSC credential generation for GNU/Linux targets is likely to work.
        OK: nsis found, LSC credential package generation for Microsoft Windows targets is likely to work.
        OK: xsltproc found.
        WARNING: Your password policy is empty.
        SUGGEST: Edit the /etc/gvm/pwpolicy.conf file to set a password policy.

It seems like your GVM-21.4.3 installation is OK.

I had tried that last night but due to many of the dependencies required to be an older version than what was currently installed (or I had put in the incorrect kali repo by accident) it would have screwed up the system. Will see if there is a docker image and try that or go back to Kali.

same problem