Cannot run Java apps (BurpSuite)

Please complete our guideline for issue report or idea suggestion

If you are having an issue, please follow this

There are many kinds of issues: OS, software, server, … So you must know:

  • Server issues will be fixed after report and we verify the problem. There will be no update patch for you. It is server side.
  • 3rd party software / packages can’t be fixed by us. If we can spot the bug and have the fix, we will create merge request to original source and wait for their official version.
  • Life is hard. For bug/ issue, please make sure your topic is only one. Dont make developers be terrorists.
  • This is a rolling distro. Bugs and issues are expected. We recommend you have basic linux knowledge to deal with your system, so
    Usually we don’t support issues that user faces by using his system in a wrong way. If you are new to Linux, make sure you didn’t make any mistake:
  1. Basic Linux: http://linux-training.be/
  2. How to not break Debian system: DontBreakDebian - Debian Wiki or How NOT to Break your Debian System! | Average Linux User
  3. If you are having some questions, your answers might be in here: FAQsFromDebianUser - Debian Wiki
  4. Your issue might be solved before (StackOverflow is a temple), try this: https://www.searchenginejournal.com/search-engines/answering-questions/

1. Your Parrot information

  • OS version: run cat /etc/*release
    DISTRIB_ID=Parrot DISTRIB_RELEASE=4.11 DISTRIB_CODENAME=rolling DISTRIB_DESCRIPTION="Parrot OS 4.11" PRETTY_NAME="Parrot OS 4.11" NAME="Parrot OS" ID=parrot ID_LIKE=debian VERSION="4.11" VERSION_ID="4.11"
  • Kernel version: run uname -a
    Linux parrot 5.10.0-6parrot1-amd64 #1 SMP Debian 5.10.28-6parrot1 (2021-04-12) x86_64 GNU/Linux
  1. How did you install OS?
    • from the Iso

4. How did you get this error? Are there any steps to procedure it?

This error appeared out of nowhere. One day I just couldn’t launch burpsuite (app installed alrdy in the OS with the security version of the os) from the graphic interface, I would launch it and it just wouldn’t open. so I started opening it by issuing “burpsuite” from the terminal. Then that started giving this error below: I even downloaded the .jar but same exact output error.

Googling the error I truly couldn’t solve this problem. I recall you the OS is fresh, I didn’t do any modifications to it besides upgrading it with the usual ‘apt upgrade’.


image

5. Error log or screenshot

└──╼ $java -jar burp.jar
Could not start Burp: java.lang.UnsatisfiedLinkError: no splashscreen in java.library.path: [/usr/java/packages/lib, /usr/lib/x86_64-linux-gnu/jni, /lib/x86_64-linux-gnu, /usr/lib/x86_64-linux-gnu, /usr/lib/jni, /lib, /usr/lib]

Fixed it with:

`sudo apt-get install openjdk-14-jre`

Then just re-run burpsuite, and it will launch.