Cannot use web browser without turning Anonsurf on

Briefly describe your issue below:
So, I can’t use Firefox or Konqueror unless I turn Anonsurf on. I know this seems like an issue repeated over and over, however it doesn’t seem like these answers to different issues solves my problem. Tried pinging, checking /etc/resolv.conf (and go lost), turning it off then rebooting, nothing works. Is there something I’m missing?

What version of Parrot are you running? Parrot Security KDE, version 4.7, amd64

What method did you use to install Parrot? Debian GTK, I think

Configured to multiboot with other systems? Triple-boot, Probably Outdated Windows 10, Linux Mint 14.1 and Parrot Security OS.

List your networking hardware (make, model, firmware version):
how do I check that

If there are any similar issues or solutions, link to them below:


doesn’t work

If there are any error messages or relevant logs, post them below:
┌─[atlas@parrot]─[~]
└──╼ $cat /etc/resolv.conf
nameserver 127.0.0.1

┌─[atlas@parrot]─[~]
└──╼ $sudo anonsurf start 
[*] killing dangerous applications
[*] Dangerous applications killed
[*] cleaning some dangerous cache elements
[*] Cache cleaned

[ i ] Starting anonymous mode:

 * Tor is not running!  starting it  for you

 * Stopping service nscd (already stopped)

 * Stopping service resolvconf
 * Stopping service dnsmasq (already stopped)

 * Saved iptables rules

 * Modified resolv.conf to use Tor

 * Disabling IPv6 for security reasons

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
 * Configuring iptables rules to route all traffic through tor

 * Redirecting DNS traffic through tor

 * Allowing only tor to browse in clearnet

 * All traffic was redirected throught Tor

[ i ] You are under AnonSurf tunnel


┌─[atlas@parrot]─[~]
└──╼ $sudo anonsurf stop

[ i ] Stopping anonymous mode:


 * Deleted all iptables rules

 * Iptables rules restored

 * Restore DNS servicenet.ipv6.conf.all.disable_ipv6 = 0
net.ipv6.conf.default.disable_ipv6 = 0
tor: no process found
\ * Restarting services
Failed to start dnsmasq.service: Unit dnsmasq.service not found.
Failed to start nscd.service: Unit nscd.service not found.
 * It is safe to not worry for dnsmasq and nscd start errors if they are not installed or started already.
* Anonymous mode stopped

Have you used anonsurf before?
If yes, you might have forgot to stop it. Once, stop the anonsurf service. For that

sudo anonsurf stop

Then restart the pc, and see if it works.

There was a former post on this same topic. You can check it here.

Doesn’t fix the issue.

Here is our explanation
https://community.parrotlinux.org/t/about-dns-problem-in-parrot-4-8/12309
Method to fix: edit /etc/resolv.conf with nameserver you want

So instead of it being nameserver 127.0.0.1, I can put gibberish 127.0.0.1?

Please read how to set DNS with resolv.conf

Thanks, I’ll try that when I’m home.

I have tried to, but it seems that dnsmasq is not installed. I have tried to install it using apt however it can’t fetch the deb file since I am forced to go through Anonsurf to access the Internet and the Parrot repository really doesn’t like that. (error 403)

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.