Can't Access GPU: NVIDIA Corporation GF108M

Briefly describe your issue below:
I’m using using Acer Travel Mate 5760 series everything is okay with him working perfectly the only 1 issue is i just wanted know how can i use my outdated NVIDIA graphics card “”"""“01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 620M/630M/635M/640M LE] (rev ff)”""""

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

    • Operating System: Parrot GNU/Linux 4.9
    • KDE Plasma Version: 5.17.5
    • KDE Frameworks Version: 5.62.0
    • Qt Version: 5.12.5
    • Kernel Version: 5.5.0-1parrot1-amd64
    • OS Type: 64-bit
    • Processors: 4 × Intel® Core™ i5-2450M CPU @ 2.50GHz
    • Memory: 7.6 GiB of RAM

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
i used Debian GTK to install parrot

Configured to multiboot with other systems? (yes / no)

  1. no

List your hardware specs to include make, model and firmware (when applicable):

  • 00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
  • 00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
  • 00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
  • 00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
  • 00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
  • 00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
  • 00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
  • 00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
  • 00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
  • 00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
  • 00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
  • 00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset LPC Controller (rev 05)
  • 00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port Mobile SATA AHCI Controller (rev 05)
  • 00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
  • 01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 620M/630M/635M/640M LE] (rev ff)
  • 01:00.1 Audio device: NVIDIA Corporation GF108 High Definition Audio Controller (rev ff)
  • 03:00.0 Ethernet controller: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet (rev c0)
  • 06:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
  • 07:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)

If there are any similar issues or solutions, link to them below:
nvidia-installer.log (1.5 KB)
I tried to install supported driver and error occurred saying kernel not supported with current kernel

If there are any error messages or relevant logs, post them below:
$nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

you can install the drivers by sudo apt install nvidia-legacy-390xx-driver

1 Like

Ok thank you let me try

Briefly describe your issue below:
i cant access my GPU after sudo apt install nvidia-legacy-390xx-driver

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Operating System: Parrot GNU/Linux 4.9
KDE Plasma Version: 5.17.5
KDE Frameworks Version: 5.62.0
Qt Version: 5.12.5
Kernel Version: 5.5.0-1parrot1-amd64
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-2450M CPU @ 2.50GHz
Memory: 7.6 GiB of RAM

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian GTK
Configured to multiboot with other systems? (yes / no)
no
List your hardware specs to include make, model and firmware (when applicable):
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 620M/630M/635M/640M LE] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GF108 High Definition Audio Controller (rev ff)

If there are any similar issues or solutions, link to them below:
┌─[✗]─[kalien@parrot]─[~]
└──╼ $nvidia-settings

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

$nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
If there are any error messages or relevant logs, post them below:
$optirun --debug hashcat
[ 5450.269715] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 5450.270491] [DEBUG]optirun version 3.2.1 starting…
[ 5450.270528] [DEBUG]Active configuration:
[ 5450.270579] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 5450.270613] [DEBUG] X display: :8
[ 5450.270629] [DEBUG] LD_LIBRARY_PATH: /usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/x86_64-linux-gnu:/usr/lib/i386-linux-gnu
[ 5450.270650] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 5450.270671] [DEBUG] Accel/display bridge: auto
[ 5450.270694] [DEBUG] VGL Compression: proxy
[ 5450.270724] [DEBUG] VGLrun extra options:
[ 5450.270756] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
[ 5450.270995] [DEBUG]Using auto-detected bridge primus
[ 5450.407764] [INFO]Response: No - error: Could not load GPU driver

[ 5450.407806] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 5450.407865] [DEBUG]Socket closed.
[ 5450.407927] [ERROR]Aborting because fallback start is disabled.
[ 5450.407958] [DEBUG]Killing all remaining processes.

I installed driver bt still no driver is loaded maybe its the nvidiaxconfig file

some helpful info to help you learn more about installing driver in question found here:

Parrot is based on Debian so everything applies except the Debian repositories (Do not add debian repositories)

Check your driver status:

lspci-k | grep -EA2 “VGA|3D|Display”

Ispci | grep -EA2 “VGA |3D|DISPLAY”
I have got intel first and nvidia second
For intel “Kernel driver in use :i915”
For nvidia" kernel modules:nvidia"

Hello
I reinstalled Parrot security (the 6th installation) Can you help me please : the steps to install nvidia geforce gt 620 driver.
Thanks