docker not working (outdated or replaced by some other docker)

*-- So, I want to make a docker image of simple flask app. but something is wrong with docker I have in my machine.

sudo docker build . -t test_version give output:
Saved file tree to doc-filelist.js
Copied JS to doc-script.js
Compiled CSS to doc-style.css`

sudo docker save test | gzip > test : (no output) does not create a zip
docker --verison : 1.0.0
which docker: /usr/local/bin/docker

I tried uninstalling docker: sudo apt-get remove docker docker-engine docker.io containerd runc
but docker still not uninstalled
and following : Install Docker Engine on Debian | Docker Documentation didnot help

I’m tired…
please help.
–*


  • Parrot version in use: Parrot OS 5.0 (LTS)"

  • Logs/Terminal output (use pastebin or similar services):

  • Screenshots:

This is how I installed it. (I made it a bash script.)

sudo apt remove docker docker-engine docker.io containerd runc

sudo apt install ca-certificates curl gnupg lsb-release

curl -fsSL https://download.docker.com/linux/debian/gpg | sudo gpg --dearmor -o /usr/share/keyrings/docker-archive-keyring.gpg

echo "deb [arch=$(dpkg --print-architecture) signed-by=/usr/share/keyrings/docker-archive-keyring.gpg] https://download.docker.com/linux/debian bullseye stable" | sudo tee /etc/apt/sources.list.d/docker.list > /dev/null

sudo apt update

sudo apt install docker-ce docker-ce-cli containerd.io

Note in the echo command, I hard coded bullseye for docker.list instead of using $(lsb_release -cs).