Dpkg: error python-faraday

Briefly describe your issue below:
after running sudo parrot-upgrade a few days ago I started getting the following error

dpkg: error processing package python-faraday (--configure):
 installed python-faraday package post-installation script subprocess returned error exit status 1

I tried sudo apt-get install --fix-broken
with no success.

I then tried ‘sudo dpkg --configure -a’
and got the traceback below

What version of Parrot are you running? (include version, edition, and architecture)
Linux parrot 4.19.0-parrot1-20t-amd64 #1 SMP Parrot 4.19.20-2parrot1.20t (2019-03-09) x86_64 GNU/Linux

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
installed from DVD several versions ago
Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:
none located after search
If there are any error messages or relevant logs, post them below:

Traceback (most recent call last):
  File "manage.py", line 14, in <module>
    from alembic.config import CommandLine
  File "/usr/lib/python2.7/dist-packages/alembic/__init__.py", line 8, in <module>
    from . import op  # noqa
  File "/usr/lib/python2.7/dist-packages/alembic/op.py", line 1, in <module>
    from .operations.base import Operations
  File "/usr/lib/python2.7/dist-packages/alembic/operations/__init__.py", line 1, in <module>
    from .base import Operations, BatchOperations
  File "/usr/lib/python2.7/dist-packages/alembic/operations/base.py", line 3, in <module>
    from .. import util
  File "/usr/lib/python2.7/dist-packages/alembic/util/__init__.py", line 4, in <module>
    from .messaging import (  # noqa
  File "/usr/lib/python2.7/dist-packages/alembic/util/messaging.py", line 3, in <module>
    from sqlalchemy.engine import url
  File "/usr/lib/python2.7/dist-packages/sqlalchemy/__init__.py", line 8, in <module>
    from . import util as _util  # noqa
ImportError: cannot import name util
dpkg: error processing package python-faraday (--configure):
 installed python-faraday package post-installation script subprocess returned error exit status 1
Processing triggers for libc-bin (2.28-8) ...
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for doc-base (0.10.8) ...
Processing 1 removed doc-base file...
Registering documents with scrollkeeper...
Errors were encountered while processing:

This error is from setup script, and --fix-broken works for debian packages only. That is why --fix-broken can’t fix your problem. Have you used faraday before it was upgraded? If yes, you have to drop your database, remove faraday user and run full upgrade again.
When you complete it, please run faraday as root user (first time must be run as root user) and let our start script create database automatically (it worked for me on parrot 4.5 fresh install).
Please comment here if you have any error. We are here to help :smiley:

1 Like

thanks for the reply. I did not think that I had run Faraday on this install at all, so I checked the database:
MariaDB [(none)]> SHOW DATABASES;
| Database |
| information_schema |
| mysql |
| performance_schema |
| phpmyadmin |
4 rows in set (0.001 sec)

It does not appear to be there…if I apt purge python-faraday and then apt install will that fix my glitch without breaking anything else?

faraday uses postgresql database. Please search with keyword faraday in the forum, you will see commands to do this task

1 Like

That worked for me.

That worked for me.
did you mean purge and reinstall?
Then i guess it is completely different problem.

Yes purge and reinstall. All it did was remove the single package .

Can you show us your apt log after purge and install python-faraday. Just its log. I guess it was missing libs or something. Just to make sure

Here you go:

Start-Date: 2019-04-02 20:04:42
Commandline: /usr/bin/apt remove --purge python-faraday
Requested-By: yo (1000)
Purge: python-faraday:amd64 (3.6.0-1parrot2)
End-Date: 2019-04-02 20:05:19

Start-Date: 2019-04-02 20:05:46
Commandline: /usr/bin/apt install python-faraday
Requested-By: yo (1000)
Install: python-faraday:amd64 (3.6.0-1parrot2)
End-Date: 2019-04-02 20:05:57

1 Like

LoL this time setup script played users LoL.

so the purge and re-install of python-faraday worked & fixed my issue with that…I just wanted to be reasonably sure it would not wreak havoc on anything else prior to my going that route.

Thanks to all for input!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.