Error running optirun after installing graphics driver.

Briefly describe your issue below:
I installed graphics driver for my laptop (Nvidia) by the official parrot os documentation link:

I ran optirun glxgears command after installing Bumblebee and Primus. And it run without a problem. At the end of the documentation they mentioned a steps related to adding some more script and editing some file to prevent screen tearing or something like that and I followed that steps too.
After restarting when I run theit gives me below error in terminal as the image attached to this post shows.


What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

Configured to multiboot with other systems? (yes / no)
Yes. with windows 10. But I think that had nothing to do with my problem. Since problem started after following last steps mentioned in the official documentation which I linked at the beginning of this post.

Hey did you fix it ? Im having similar issue !

No, I don’t have a clue. Moreover this forum doesn’t even take notice of such things.

reinstall the drivers
someone posted similar issue
he fixed his issue by removing all the installed software and reinstalling it

LoL That was me !

Try this !!

If you have same problem then reinstalling nvidia drivers and going through docu will solve your problem. Thats how I did it !

1 Like

Can you point me to a document how to uninstall the drivers properly ?

if it is just nvidia drivers
sudo apt remove nvidia-driver

Actually I think that nvidia+Dell doesn’t work properly on Linux, not sure why !
I ran into same problem today, that I ended up with broken nvidia driver and I couldnt avail it. I did everything from documentation again and couldn’t even do the test runs(Because of broken package I guess). So basically getting nowhere, I guess from constant re-installation, some packages must have got busted.
So if that happens to you even after reinstalling the drivers(Using apt command as shown in documentation) and removing files you have created from documentation. I suggest you to do what I did.

Error was this with broken nvidia-driver:

______$ lspci -v 

    01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev ff) (prog-if ff)
            !!! Unknown header type 7f
            Kernel modules: nvidia

And this is my optirun error:

____ $optirun -vv glxgears
[ 2282.865206] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 2282.865487] [DEBUG]optirun version 3.2.1 starting...
[ 2282.865492] [DEBUG]Active configuration:
[ 2282.865494] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 2282.865496] [DEBUG] X display: :8
[ 2282.865498] [DEBUG] LD_LIBRARY_PATH: /usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/x86_64-linux-gnu:/usr/lib/i386-linux-gnu
[ 2282.865500] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 2282.865502] [DEBUG] Accel/display bridge: auto
[ 2282.865504] [DEBUG] VGL Compression: proxy
[ 2282.865506] [DEBUG] VGLrun extra options: 
[ 2282.865508] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
[ 2282.865593] [DEBUG]Using auto-detected bridge primus
[ 2282.865779] [INFO]Response: No - error: Could not enable discrete graphics card

[ 2282.865786] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card

[ 2282.865788] [DEBUG]Socket closed.
[ 2282.865794] [ERROR]Aborting because fallback start is disabled.
[ 2282.865797] [DEBUG]Killing all remaining processes.


  1. I went to official nvidia site to download driver for my graphics card(
  2. Make sure you have nothing installed related to nvidia(from apt or anything that case) before installing file . If you have then you must delete/remove them. undo everything from documentation as well… except removing this file /etc/modprobe.d/blacklist-nouveau.conf do not delete it because its necessary in future.
  3. Then I logout of the system and went to login screen pressed alt+ctrl+f1 .
  4. Login again as user. and stopped lightdm service that is necessary for installation using sudo service lightdm stop
  5. Next thing I did was installing the driver as root.
  6. When the installation was success, reboot the system. Now see if the driver is there using lspci -v , if it is then uninstall the driver and follow the documentation again and Now doing the test run, it works fine.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.