Errors updating system

Briefly describe your issue below:
Had to reinstall system and now getting console errors when installing anything in anyway.

What version of Parrot are you running? (include version, edition, and architecture)
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian standard
Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
dpkg: dependency problems prevent configuration of console-setup:
console-setup depends on console-setup-linux | console-setup-freebsd | hurd; however:
Package console-setup-linux is not installed.
Package console-setup-freebsd is not installed.
Package hurd is not installed.

dpkg: error processing package console-setup (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:

Problem solved…Reinstalled system again.

did you figure out or narrow it down as to the culprit behind the behavior? Ive never received this error so Im very curious! did you get your gnucash figured out?

Hi and thanks for the response.
Over the years I have used .iso to load and try many different os’s with very few problems. For some reason I have had a lot of problems with the parrot iso’s. I have used them on 2 different systems both by dvd’s and usb flash drives. I don have problems writing them to dvd or usb but with the installation. The system that was giving me problems had not completely finished updating the packages when it stopped and I had to continue the update by sudo dist-upgrade. It seemed to work ok but the error I was having was caused by this and I figured I best reload the system again.
Thanks for your interest.

As far as GNUCash goes I had it working with the snap version but with some errors which bothered me, especially on a finance program. I finally deleted the snap version when I saw that debian testing had added gnucash to its repo. Tried to load via parrot but not available yet.