Ethernet card not recognized during install

During install I have been stuck on trying to get the ethernet card configured. The iwlwifi drivers are shown, but when i select them and choose “continue” nothing happens and I cannot progress. I tried flashing with both rufus and etcher to no avail. tried Parrot OS versions 9.9.1, 9.9 and 9.8. I’m sure I’m not the only one with this issue, but finding the answer has proven very difficult. Any help would be appreciated. I don’t need handholding I don’t think, just a link to a good working tutorial and I should be fine. Thanks!

Briefly describe your issue below:

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64) parrot security 4.91 x64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
I’ve tried Standard,GTK,Live
Configured to multiboot with other systems? (yes / no)
No.
List your hardware specs to include make, model and firmware (when applicable):
HP Spectre with ipwl 7625
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

1- Old machines can get cards incompatibilities problems. In mine I only get boot in Parrot 4.9.1 changing BIOS to UEFI. With BIOS in Legacy a get kernel panic

You can try Parrot 4.5 and change repository list to debian and use normally

2- What problem are you having with flash USB?
If is not booting, change the boot sequence in BIOS to USB-CD first
Or burn a DVD

IWLWIFI is for wifi, not ethernet. Yes I know it probably shows up there it really shouldn’t but also unless you have a netinstall image you don’t need to configure any networking to install. Skip that part and move on.