Exfat USB key are no longer recognized

Hello,
After upgrading my Parrot Security system by running sudo parrot-upgrade, I am no longer able to mount my USB keys formatted in exfat. It worked perfectly before (since the 4.7). These USB keys work on Windows and on Parrot Security 4.9. Others USB keys work without any problem (fat32, ext4). I have the same problem on an other computer with the same OS, but in dual boot with Windows.

When I try to access to the USB key with Dolphin, I get this message : An error occurred while accessing 'lasercata', the system responded: The requested operation has failed: Error mounting /dev/sdb at /media/lasercata/lasercata: unknown filesystem type 'exfat'

I tried to install exfat-fuse and exfat-utils, but they were already installed and to the last version. Removing and re-installing them didn’t helped.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

$ uname -a

Linux parrot 5.6.0-2parrot1-amd64 #1 SMP Debian 5.6.14-2parrot1 (2020-05-23) x86_64 GNU/Linux

$ cat /etc/os-release

PRETTY_NAME=“Parrot GNU/Linux 4.10”
NAME=“Parrot GNU/Linux”
ID=parrot
ID_LIKE=debian
VERSION=“4.10”
VERSION_ID=“4.10”
HOME_URL=“https://www.parrotsec.org/
SUPPORT_URL=“https://community.parrotsec.org/
BUG_REPORT_URL=“https://community.parrotsec.org/

DE : KDE 5.70.0 / Plasma 5.17.5

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian GTK (graphical install)

Configured to multiboot with other systems? (yes / no)
no

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

See solution here:

1 Like

Thanks, this worked for me.

2 Likes

Hello!

Thanks for your inputs! I tried this method and in fact it didnt work. I also tried a few other methods on another post. (Link: Unable to mount exfat/android after latest update {SOLVED})

Post:

Hello All!

Thanks for all your inputs on these!

I seem to still have the same issue.

1: USB was not mountable

2: First thing I tried:

sudo apt-get install exfat-fuse exfat-utils

This returned: “already newest version”

3: Then tried: sudo mkdir /media/exfat

Followed by

sudo mount -t exfat /dev/sdb1/media/exfat

This returned: mount: /dev/sdb1/media/exfat: can’t find in /etc/fstab.

4:
sudo add-apt-repository universe
sudo apt update
sudo apt install exfat-fuse exfat-utils

“0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.”

5: Tried your last trick: mount.exfat-fuse /dev/sdb1 /mnt/exfat
returned:
“FUSE exfat 1.3.0
ERROR: failed to open ‘/dev/sdb1’: Permission denied.”

Changed the b1 to b2 :
mount.exfat-fuse /dev/sdb2/mnt/exfat

Returned:

FUSE exfat 1.3.0
Usage: mount.exfat-fuse [-d] [-o options] [-V]

6: Last thing I tried: ln -s /usr/sbin/mount.exfat-fuse /sbin/mount.exfat
ln: failed to create symbolic link ‘/sbin/mount.exfat’: Permission denied

Nothing I do is working. Not sure What I can do!

Many thanks to anyone who replies! Cheers!