Fail on 'Install the system'

So, I have made a flashable USB. Everything works fine during installation until “Install the system”. I have formatted an entire HDD in order to install Parrot. But every times, it fails on install the system. I tried installing in two computers but both gives me the same error. How do I install now?

Parrot OS security, both amd64 and i386.

Method of install: Debian GTK and standard.

**Configured to multiboot with other systems?: No.

Hi there!! What software did you use for making the USB bootable?


I have the error below whilst trying to launch the installer on live…I am on Macbook Pro 2010 model…

Any help would be appreciated.


╼ $sudo /usr/sbin/debian-installer-launcher --text
Loading debian-installer…

gzip: /lib/live/mount/medium/install/gtk/initrd.gz: invalid compressed data–format violated
non-network local connections being added to access control list
Starting system log daemon: syslogd, klogd.
/lib/debian-installer-startup.d/S30initrd-preseed: .: line 4: can’t open ‘/usr/share/debconf/confmodule’
/bin/env2debconf: .: line 5: can’t open ‘/usr/share/debconf/confmodule’
/bin/preseed_command: .: line 5: can’t open ‘/usr/share/debconf/confmodule’
/lib/debian-installer-startup.d/S37alsa-utils-udeb: .: line 3: can’t open ‘/usr/share/alsa/’
/lib/debian-installer-startup.d/S60auto-install: .: line 3: can’t open ‘/usr/share/debconf/confmodule’
/lib/debian-installer-startup.d/S60rescue-check: .: line 4: can’t open ‘/usr/share/debconf/confmodule’
touch: /var/run/brltty-Xorg: No such file or directory

You cant install from a live usb, its a known bug.

1 Like

Hey man,

Thanks. I also have problem running it from usb installer option, stuck at installing base system. The same usb is working fine for other machine.

hmm, i never worked with any apple product :confused:

after a frustrating evening going through similar hardships, I was able to install ParrotOS 4.1 Home version by booting the live DVD and selecting the GTK Install from the live menu…this was the ONLY option that worked.

Now I just need to figure out what packages need to be installed to bring it up to the full “ParrotOS Security” Distro

sudo apt install parrot-tools-full
This install the tools that in ParrotSec

thanks much for the rapid reply!

1 Like

I’m having the same problem, so I tried installing the parrot home edition. It’s worked smoothly but when I wanted to install the Parrot-Security tool in my home edition using “Sudo apt install parrot-tools-full” command in the terminal, it downloaded all the tools but then an error popped up saying “Unable to fetch some archives, maybe run apt-get update or try with - -fix-mixing?” I even tried using this command but I had no luck. I don’t know what to do. Hope that u can reply!

sudo apt update && sudo apt dist-upgrade && sudo apt install parrot-tools-full

Again no luck…

I just installed parrot full version from the usb live, after many failed attempts. I was often stuck on the failed to install error before it worked.