Firefox always in Sandbox

Briefly describe your issue below:
I want to use different profiles in Firefox but I always end up with the sandboxed profile /etc/firejail/firefox.profile

How can I change the profile? Only things I can find are instructions how to jail Firefox :frowning:


What version of Parrot are you running? (include version, edition, and architecture)
Parrot 3.11 stable
4.14.0-parrot13-amd64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard

Configured to multiboot with other systems? (yes / no)
Yes

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
$firefox --ProfileManager
Reading profile /etc/firejail/firefox.profile
Reading profile /etc/firejail/disable-common.inc
Reading profile /etc/firejail/disable-devel.inc
Reading profile /etc/firejail/disable-programs.inc
Reading profile /etc/firejail/whitelist-common.inc
Reading profile /etc/firejail/whitelist-var-common.inc
Parent pid 28808, child pid 28809
Blacklist violations are logged to syslog
Child process initialized in 97.82 ms

Parent is shutting down, bye...

You can modify firefox.profile or remove firejail.

Thanks for your reply. The firefox.profile says that it will be overridden after an update. How can I make changes persistent? I know there’s firefox.local for that purpose, but I don’t know how to “unset” things that have been set in the firefox.profile.

Let’s say private-tmp is set in firefox.profile but I want to unset it in firefox.local. How would I achieve that?

firefox.local will not be overridden after upgrades so there is where you make persistent changes. If you have a symlink in firefox.profile (which shoud be there) linking to .local then .local will be read first and takes effect.

Simply add and/or delete lines in your.local file and you should be ok.

I forgot to mention that you have to create any .local file manually. :slight_smile:

OK, just to be clear: If there’s a .local, the .profile will be ignored completely? I would just copy firefox.profile to firefox.local and edit this, so I’d be all set…

Sort of. Your .profile already has a symlink to to a .local file (read one and you’ll see it there) so what you do is copy that .profile file and make additions (or omissions) and save it in the same directory as firefox.local. In this way firefox will start using the new .local file.

EDIT: Save the new .local file in /etc/firejail.

if you want to start firefox with a different profile, then run the “firefox profile manager” from the applications->internet menu

remember that you can have only one firefox profile running, and no concurrent profiles can be run in parallel

also remember that firefox profiles are not different firefox sandboxes

additionally, if you want, you can manually run your custom firejail (sandbox) profiles by manually running firejail [additional options] firefox