Globalstar BU-353-S4 USB gps

I recently bought this GPS unit but I can’t seem to get it to work properly. Has anyone else got it and if so, have you had issues with it? How did you get it to work in the first place?

thanks in advance and kind regards,

What version of Parrot are you running? (include version, edition, and architecture)
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard
Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:
If there are any error messages or relevant logs, post them below:

Never used one but if you try google there seems to be a few tips including some videos on how to get set up.
But maybe look at these:

Hey, thanks! I already found the link you posted and tried it but unfortunately didnt work. I’ve looked around extensively and tried different methods , also from youtube vids. The pdf you linked is new to me, though. I’ll look into it in a bit!