Hashcat Can't Find GPU

Briefly describe your issue below:

Hashcat can’t see my GPU (and thus can’t use it for decrypting).

sudo hashcat -I

Device ID #1
Type : CPU

Notice, there are not 2 devices, but there should be (CPU and GPU).

Before someone says it, I’ve followed Hashcat’s solution to an exact, and I’ve tried other forums but no luck.

I have GEFORCE GT 730

Let me know if you would like to see other outputs.

P.S. running “lspci -v” DOES show my graphics card, but hashcat doesn’t.

What version of Parrot are you running? (include version, edition, and architecture)
Parrot 4.4 64bit

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian standard

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

You need to install some extra bits.

After i installed nvidia-cuda-toolkit it didnt show up in hashcat straight away, but after i had done some de-bugging i checked back and it was working. Was a bit odd since i didnt change anything, so make sure you reboot afterwords ect just to make sure.

So just tried on another machine and got it working.

sudo apt update
sudo apt-get install nvidia-cuda-tookit
sudo apt-get install clinfo
hashcat -I

You should now see the card.

1 Like

I will try doing this soon, but my GPU was not on the CUDA supported list on that link you sent. Should I even bother trying?

I know Parrot supports my card (as the website says and lspci shows), but is hashcat CUDA specific or is there another method?

So here is a different set of lists https://developer.nvidia.com/cuda-gpus

I only linked GeForce cards on that post. You can see how many CUDA cores your card has in the ‘Nvidia X server’ application.

Hashcat uses OpenCL, nvidia uses CUDA, CUDA supports OpenCL. If that makes sense.
Nvidia > CUDA > OpenCL > Hashcat.

After that it bricked my OS. Now I have to reinstall. Anybody else have suggestions?

For intel CPU and GPU (onboard), You should find and install intel-opencl version 16. Intel released version 18 on github and it doesn’t work for me. I don’t know about AMD / NVIDIA graphic card so i guess you can ask about it on hashcat forum.

if your HW isnt on the list it may not be supported. whats the gpu?

It is a GEFORCE GT 730.

sudo apt install -y ocl-icd-libopencl1 nvidia-driver nvidia-cuda-toolkit should work perfectly.