Hashcat >> No devices found/left

hello all i have problem when i run hashcat
i 'am installed nvidia driver and apt install hashcat*
lenovo y50-70
nvidia 960 m 4k
Processor: Intel® Core™ i7-4720HQ CPU @ 2.60GHz × 8
Memory:15.6 GiB

I’ve found that many issues I might have using Hashcat are resolved using sudo. Anyway that may be not your case because looks like no hardware is detected. What hardware are you working with?

please post in the appropriate Support category rather than the Community general page; be sure to fill out the provided info chart given by default as well or you may not have enough information for anyone to respond

I cleaned the other post for you, thank you for getting that corrected, I still don’t have the table with the version number etc. though so next time just don’t delete it but fill in the fields and just leave it at the bottom. did you make sure you had all of the nvidia packages installed? A good place to see it is synaptic. if you could post your lspci grep vga output that may answer the issue as well.

I had to install nvidia-cuda-toolkit and clinfo, then i was able to use hashcat.

Make sure your card supports ‘cuda’ first: https://www.geforce.com/hardware/technology/cuda/supported-gpus

clinfo for debugging.

nvidia-cuda-toolkit totals over 2G of packages… I dont know if all those packages are needed, so it might be overkill.

clinfo and nvidia-cuda-toolkit was installed

and i treid but not work

just to be sure what is the gpu you are trying this on?

Just got it working again on another machine, with a different card using: Hashcat Can't Find GPU

Installing nvidia-cuda-toolkit and restarting the computer doesn’t work for me. Opening hashcat still produces “No devices found/left.” Any other ideas? (Using a GTX1080Ti)

I still had to run clinfo afterwards.

I ran clinfo and it shows everything, but running “hashcat -I” after that still says “No devices found/left.”

You could create your own thread and we can have a go at fixing it. Although im not sure why it wouldnt be working.

Hey, have you setup your gpu properly: installed the drivers ? installed bumblebee +primus since you have 2 gpu ?
If you have done all that, to run hashcat with your nvidia you have to run this:

optirun hashcat -b

if it doesnt work (like me) you have to run it with sudo (i dont like this solution but i didnt find any other):

sudo optirun hashcat -b

Dont follow kali tuto (or ubuntu tuto) for parrot, even though they are all debian based, a lot of thing make them different. We have an nvidia tuto here on the forum:

1 Like

since im poor and stupid and only turn left. i got " budget cards" first build and it takes me 3 tries to plug in a usb. point is are they legit? i got what i paid for. showed up but never worked now getting replacing one a pay day. the rig looked sweet had to make work. real ones no probs. execpt allhambros got i doubt real 2080 ti’s for $2 bucks each lol. but i live in an ev in atllantic city live live off mining scraps i take to craps. wtf ill roll the dice for 12 bucks . again be sure cards r real. with other topics