Having problems with 03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8822CE 802.11ac PCIe Wireless Network Adapter

– Please Write here your help request, –


  • Parrot version in use (if you are not aware of it, open terminal and type cat /etc/os-release | grep VERSION):

VERSION_ID=“5.0”
VERSION=“5.0 (LTS)”
VERSION_CODENAME=bullseye

  • Kernel version (if you are not aware of it, open terminal and type uname -r):
    5.14.0-9parrot1-amd64

  • Logs/Terminal output (use pastebin or similar services):

  • Screenshots:

I’m new in parrot OS. I’ve dual booted pc with windows 11 and parrot.
I was having real issues with wifi driver.
Previously it showed no internet after every 2-3 mins and reconnect worked fine.
Now I’ve installed a driver of RTL8822CE 802.11ac PCIe from github.
now I’ve wlan0 and wlan1.
But currently the problem is the net works. But after every 2-3 mins it becomes 0 kbps. During video calls it really hurts.
Please help me with this. I’m getting too frustrated!!!

Same issue, same kernel, same dual boot

Hello guys. Is the one you installed an official driver? The driver you need should be called firmware-realtek, and if I remember correctly it’s in our repositories. Otherwise, search for it on Debian and download the .deb file, then sudo apt install -f firmware-realtek.deb and you should have solved.

In the parrot update was solved the problem, but then i have the same problem again.
In this case i detect what it’s the cause, i work with vmware, i install windows VM, and all ok, but some days later, i install dual boot in the VM, with ubuntu, and in this presice moment, after run ubuntu, i lost wifi. I try all, and nothing work.
I uninstall ubuntu, unistall vmware, reinstall drivers, firmware, all, and nothing work.
My solution it’s wait for parrot update, and have a look the driver work again.

And finish, today i update a parrot kernel, and the wifi work again.