Help! ParrotSec installation problem

parrotsec

(MrtnBlck) #1

Hi! I tried to install parrot sec os many times (4.5 and 4.5.1 too) from usb. I did it with rufus (gpt, at first as iso, then as dd)
I tried to do it with standard installation, it was fine. When I booted parrot, first i a screen appeared with 4 options: {-Parrot GNU/Linux; -Advanced options for Parrot GNU/Linux; -Windows Boot Manager (on /dev/sda1); -system setup} I chose the first one, then the animated loading screen appeared, and then a similar black screen showed up with the following text:
“Parrot 4.5 parrot tty1
parrot login:
(If i write nothing, some codes appear: [ 53.766587] ACPI Error: Method parse/execution failed _SB.PCI0.PEG0.PG00._ON… etc.” .
I gave my username and password there, acces was granted, but i could not get to the desktop.
If i choose any other option in the first screen, for example: advanced options… I can’t do anything with either of these options.
I don’t know what I should do, please help me out :slightly_smiling_face:


(vladislav) #2

As far as I understood, you are able to login in shell.
You can try to start desktop with startx command.

Also you can try to boot with acpi=off option. To do that you need to:
1. Select Parrot GNU/Linux
2. Press “E” button.
3. Find a row starting with linux and at the end of this line write acpi=off
4. Press “Ctrl+X” to boot.


(MrtnBlck) #3

Thanks, I hope it will work! :smile:


(Anirban) #4

I would suggest you to use “Etcher” to flash your pendrive with the iso file.Cause “Etcher” is specially developer to flach linux iso in pendrive.
And also try to get a new iso file cause maybe the one you have is corrupted.