Help with Nvidia Drivers

parrot
nvidia
(vladislav) #21

then try sudo journalctl -xe | grep bumblebee

(Jayesh Mann) #22

no output still

(vladislav) #23

Have you even installed bumblebee?

(Jayesh Mann) #24

Yes I have installed sir

(vladislav) #25

I think the daemon isn’t even running then, check that with

service status bumblebeed
(Jayesh Mann) #27

Status : unrecognised service

(Jayesh Mann) #28

optirun glxgears
285 frames in 5.0 seconds = 56.967 FPS
301 frames in 5.0 seconds = 60.033 FPS
301 frames in 5.0 seconds = 60.031 FPS
301 frames in 5.0 seconds = 60.022 FPS
301 frames in 5.0 seconds = 60.036 FPS
301 frames in 5.0 seconds = 60.029 FPS
301 frames in 5.0 seconds = 60.029 FPS
301 frames in 5.0 seconds = 60.021 FPS
301 frames in 5.0 seconds = 60.041 FPS
301 frames in 5.0 seconds = 60.025 FPS
301 frames in 5.0 seconds = 60.029 FPS
301 frames in 5.0 seconds = 60.028 FPS
301 frames in 5.0 seconds = 60.036 FPS
301 frames in 5.0 seconds = 60.027 FPS
X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
Major opcode of failed request: 154 (DRI2)
Minor opcode of failed request: 7 (DRI2GetBuffersWithFormat )
Resource id in failed request: 0x4200002
Serial number of failed request: 13275
Current serial number in output stream: 13275
primus: warning: dropping a frame to avoid deadlock
primus: warning: timeout waiting for display worker
terminate called without an active exception

(vladislav) #29

I am still confused, have you installed bumblebee? Is there any output of ls /etc/bumblebee?

(Jayesh Mann) #30

ls /etc/bumblebee/
bumblebee.conf xorg.conf.d xorg.conf.nouveau xorg.conf.nvidia

(vladislav) #31

Alright my fault.

service bumblebeed status
1 Like
(Jayesh Mann) #32

service bumblebeed status
● bumblebeed.service - Bumblebee C Daemon
Loaded: loaded (/lib/systemd/system/bumblebeed.service; enabled; vendor preset: e
Active: active (running) since Thu 2019-05-09 14:45:42 IST; 28min ago
Main PID: 658 (bumblebeed)
Tasks: 1 (limit: 4915)
Memory: 1.5M
CGroup: /system.slice/bumblebeed.service
└─658 /usr/sbin/bumblebeed

(Jayesh Mann) #33

please reply quickly sir, i want to solve this problem asap

(vladislav) #34

Please respect me and my time. I see when you make a post, but I am also a busy person with my own problems.

Run

optirun -vvv echo a
2 Likes
(Jayesh Mann) #35

optirun -vvv echo a
[ 114.936725] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 114.937000] [DEBUG]optirun version 3.2.1 starting…
[ 114.937008] [DEBUG]Active configuration:
[ 114.937010] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 114.937013] [DEBUG] X display: :8
[ 114.937016] [DEBUG] LD_LIBRARY_PATH: /usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia
[ 114.937019] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 114.937021] [DEBUG] Accel/display bridge: auto
[ 114.937024] [DEBUG] VGL Compression: proxy
[ 114.937027] [DEBUG] VGLrun extra options:
[ 114.937029] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
[ 114.980985] [DEBUG]Using auto-detected bridge primus
[ 117.252549] [INFO]Response: Yes. X is active.

[ 117.252567] [INFO]Running application using primus.
[ 117.252693] [DEBUG]Process echo started, PID 1648.
a
[ 117.288934] [DEBUG]SIGCHILD received, but wait failed with No child processes
[ 117.289011] [DEBUG]Socket closed.
[ 117.289063] [DEBUG]Killing all remaining processes.

(Jayesh Mann) #36

If my problem doesn’t solves,I think I will go ahead with Kali , overwriting parrot. Tho I installed parrot only cuz it can be used for student works too.

(vladislav) #39

Sir, I want you to understand two things:

  • Problem CANNOT solve itself. You have to be patient if you want some help.
  • If you want to try going with Kali, go ahead, but keep in mind that it’s also a debian distribution and you will face the same problem, because the problem is not with the ParrotOS but with NVIDIA drivers and bumblebee.

I also remind you that I am not bumblebee developer, I am a guy who messed with it a lot. I could say in any moment something like “Bumblebee and NVIDIA is not ParrotOs problem, so go to bumblebee/nvidia forums and find your answers”, but as you may see, I am not that junkass and I am trying to help you. So please just be patient.

That looks like everything fine with your optirun and bumblebee configuration.

I don’t understand how your bumblebee is installed, how is it even capable to run apps if there is no daemoon log in journalctl or dmesg. That is weird. And what’s up with your GUI? I really feel like you don’t say me something… So please provide me this info.

2 Likes
(Jayesh Mann) #40

GUI is working properly now sir…I think you skipped reading my message after startx

(Jayesh Mann) #41

sudo journalctl -xe | grep bumblebee
[sudo] password for jay:
– Subject: A start job for unit bumblebeed.service has finished successfully
– A start job for unit bumblebeed.service has finished successfully.
May 12 16:09:03 parrot bumblebeed[660]: [ 23.092781] [INFO]/usr/sbin/bumblebeed 3.2.1 started

closed #42