Help with Nvidia Drivers

nvidia
parrot
(Jayesh Mann) #1

Not able to install nvidia drivers correctly after following tutorial from pinned topic.

What version of Parrot are you running? 4.6 edition KDE Security amd64

What method did you use to install Parrot? Debian GTK

Configured to multiboot with other systems? yes

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
prime-select : command not found
glxgears not found

(vladislav) #2

Hello. Please tell me what guide did you follow.

In order to make glxgears test install meta-utils package. We are sorry for not providing this info, we will fix this asap.

sudo apt install mesa-utils

After that you should be able to run glxgears.
Also please check out our official guide: https://www.parrotsec.org/docs/info/gpu-drivers/

(Jayesh Mann) #3

I used the guide linked below…
https://community.parrotsec.org/t/tuto-install-of-bumblebee-and-drivers/5706/17

Now after following the docs guide you linked me to, Parrot doesn’t boot, opens parrot tty1

#4

what is your GPU card?? and in the official guide dont follow the final step where they edit all xorg file… i tried mutliple time and finally win without editing all those files… :wink:
And i have a GeForce 920Mx and i install the driver 410 not the 390xx

(Jayesh Mann) #5

GPU is MX150… HELP me ,cuz parrot is not booting with GUI now

(Kilian) #6

Hi, i guess it is an acpi issue (if the guide was followed properly) , what is your exact laptop model ?

(Jayesh Mann) #7

Asus Vivobook s510 UNR core i5 8th gen GPU mx150.

(Jayesh Mann) #8

I tried booting with both modes, Nvidia off and aicp off, but it opens parrot tty1.

(Jayesh Mann) #9

I’m new to Linux.

(vladislav) #10

Please don’t tell people what not to do if you don’t know what it is.

The first xorg config is to resolve issue with screen teraring which appears when you use Intel cards. Of course you could avoid using that, and end up with bad screen experience.

The second xorg config modifies nvidia-generated xorg file, which can lead to multiple issues, and you have to add the script so bumblebee work. TBH I don’t remember how exactly that error looked, but I was struggling with NVIDIA for 6+ months, so I know a little.

(vladislav) #11

Try booting and start GUI explicitly by this command:

startx

It will show errors, why parrot doesn’t boot, so we can investigate this problem further.

(Jayesh Mann) #12

i removed both the files and rebooted 5 min ago and gui booted after showing tty1 for 1 sec

(Jayesh Mann) #13

will use startx someday

(Jayesh Mann) #14

on terminal, i give nvidia-settings command,it returns…
ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(vladislav) #15

Why someday? You have an error - I propose you to solve it and you just say “someday”? Do you need help or not?

(vladislav) #16

If you are using Intel card, nvidia-settings won’t work - because nvidia module isn’t loaded.
If you are still using bumblebee try optirun nvidia-settings.

(Jayesh Mann) #17

sudo optirun nvidia-settings …
ERROR: Unable to load info from any available system

(vladislav) #18

Try again and then drop here the output of

sudo dmesg | grep bumblebee
(Jayesh Mann) #19

Ok sir, trying now…

(Jayesh Mann) #20

No output sir