Hibernate disappeared

– My laptop always used to hibernate when i closed the lid and then all of a sudden it no longer does. I’ve tried systemctl hibernate and the output is “Failed to hibernate system via logind: Not enough swap space for hibernation”
This is wierd because i could always hibernate when closing the lid.
Can someone please tell me how to fix this ? –

  • Parrot version in use 4.11 (if you are not aware of it, open terminal and type cat /etc/os-release | grep VERSION):

  • Kernel version (if you are not aware of it, open terminal and type uname -r):

  • Logs/Terminal output (use pastebin or similar services):

  • Screenshots:

Hello. How much space have you allocated to the swap partition? It may no longer be sufficient as the error reports.

I didn’t change the size of my swap partition.

I’ve since tried the following commands & this is the result.

[sudo echo disk > /sys/power/state
bash: /sys/power/state: Permission denied]

Try the same command as root user

I think i’ve fixed it by editing the sleep.conf file. It’s just strange because i was always able to hibernate before. Why would someone hack my machine and edit my sleep.conf file, That’s so strange.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.