how to set time

Briefly describe your issue below:
I am running 3.11 64 bit and the time shown is 5 hours early. I have checked the location setting and it is set right. I am in the est which is what it says but the time is not right. How do I fix it?
Thanks


What version of Parrot are you running? (include version, edition, and architecture)

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

try to fix your time in the system time settings

Give me a break I did that first and it didn’t work. I had to go into my bios and add 5 hours to the time to fix it artificially. There is obviously a problem with this os

why this os and not debian? the system is based on it and NOTHING related to the time settings was modified by us

1 Like

I still cannot change the time wheter I do it through control panel or sudo date --set in the terminal

EDIT: worked in Kali

Try this:

sudo rm -f /etc/localtime
sudo ln -sf /usr/share/zoneinfo/“your country”/“your city” /etc/localtime

For example: Mine would be sudo ln -sf /usr/share/zoneinfo/America/Chicago /etc/localtime