hplip problem with ColorJet scanner/printer/fax

Hi guys,
once again someone with hplip problems

This software is really piece of sheet…
It worked like a charm on arch but the machine was useless , I tried the new parrot version on my new laptop and back to hell…

1. Your Parrot information

  • OS version: run cat /etc/*release
    4.10
  • Kernel version: run uname -a
    4.8.5 xanmod 4.7.10 from parrot
  1. How did you install OS?
    • Debian installer or Calamares installer?
      using Calamares

3. If your hardware doesn’t work: wifi doesn’t show, graphic issue:

- Did you try searching info about this issue on search engine? 

yes searched through many pages on Ubuntu forums/ debian forums/ HP developers portal/stackoverflow …

4. How did you get this error? Are there any steps to procedure it?

running hp-setup or hp-plugin

5. Error log or screenshot

note: Using PyQt5
warning: parrot distro is not found in AUTH_TYPES
error: Password incorrect. 2 attempt(s) left.
error: Password incorrect. 1 attempt(s) left.
error: Password incorrect.
Plugin installation failed
error: Python gobject/dbus may be not installed
error: Plug-in install failed.

6. If you have any idea or suggestion about this issue please tell us

Parrot is not listed inside the well known distros list, I guess that authentication using Python lib tries to use root account rather than sudo and authentication

2. Its section and how it affects our system

not crucial but I need scanning & printing and printing is working partially (no duplex printing and not all features activated, scanning fails, scanner communication fails fron xsane or simple-scan)

3. Any other information about this idea

I tried many things specifying alternate Python version/ using latest .run file from HP but I am unable to succeed hp-setup process with different problems:

  • authentication failure (unable to enter my pseudo root password) , I tried to use simpler password but no way… I tried to use Ubuntu rather than Debian during setup because it changes the way python does authentication but no way it always fail

result my scanner is unusable
my printer works but in degraded mode (no full duplex)