I can't resolve DNS on a particular network

My system doesn’t seem to be able to resolve DNS on my home network

sys info:
Release 4.10 64-bit
Kernel Linux 5.8.0-2parrot1-amd64 x86_64
MATE 1.24.1

It started after i tried to run anonsurf for the first time in a long while. Although anonsurf i couldn’t access internet while anonsurf was on, after i switched it off i could no longer access the internet on my browser and terminal. But i can access the internet while running tor browser on its own.

this issue seems to be particular to my home network

I tried

  • sudo resolvconf -u
  • sudo dpkg-reconfigure resolvconf
  • sudo dhclient
  • I even added nameservers

but none worked

I’m sure there’s something else I’m missing

Try:

sudo anonsurf stop

See if that further reverses any changes for you.

Thank you for the reply, I tried that but it didn’t work

" Anonsurf is not running! Can’t stop nothing "

Try the dnstool command.

It would help to know the exact problem. Try running Wireshark and see what kind of connection problems come up on a normal browser.

1 Like

Thank you.

I used wireshark to analyze my network traffic and noticed every-time i tried to make a request via browser my routers responded with an “ARP who is”, so i connected to my phones hotspot and ran:

“sudo anonsurf stop && sudo parrot-upgrade”

and upon reboot everything was fixed the issue was caused by anonsurf i believe

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.