I have a problem with Metasploit

Hello everyboady…
i Have this massege for metasploit

and armitage is not working
Help me Please

The log shows a nonstandard directory being referenced, how was it installed?

i’m using this command

apt-get install metasploit-framework

Try the reinstall command. Use apt, apt-get is outdated. Nothing should be in the /opt directory by default, this is strange. What is your sources list…

# deb cdrom:[Debian GNU/Linux 4.4 _Parrot_ - Official Snapshot amd64 LIVE/INSTALL Binary 20181123-17:21]/ parrot contrib main non-free

#deb cdrom:[Debian GNU/Linux 4.4 _Parrot_ - Official Snapshot amd64 LIVE/INSTALL Binary 20181123-17:21]/ parrot contrib main non-free

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.

please read this

https://www.parrotsec.org/docs/mirror-list/

Then once you have set up your mirror as per the instructions, open a terminal and type “sudo parrot-upgrade”

not working :frowning:

If your system is 4.4 you must update first before we an see if there are trully any problems, there is no way (or point at attempting) to work around this. You can update and upgrade (there is copious documentation on this simple procedure and has already been mentioned) or download and install using the latest iso.

I might choose the second one because the screenshot makes no sense, the package manager does not install anything into the /opt directory by default so if you indeed installed from the repository then you have big file system problem.