I messed up my keyboard layout….. I’m new and lost

I changed my keyboard layout to something weird im missing ((super key, caps lock, tab, backspace, esc, delete, all f keys, 56qwertyuiopgh)) if I press ((fn & z)) I get a backslash, hopefully that’s good. The hard part is I encrypted my entire drive and have a very long pass phrase. I can’t open terminal. I’ve tried booting from usb but no power key (power button works) all I can see is American megatrends
Version 2.18.1263.copyright (c) 2020 American megatrends, inc.
Bios date 4/25/20 14:13:38 ver: 3bans010
Press Or To enter setup. Welcome to grub

Attempting to decrypt master key…
Enter your passphrase for Hd1,gpt2

I have parrot os 4.11 (xfce I think) this is my first real attempt at Linux so I’m not to sure how to work for additional info.

Any advice would be greatly appreciated. Hopefully that’s enough bread crumbs to get started. Oh and for whatever it’s worth, it was a pretty cool os before I broke it…. My bad

You are in quite a pickle aren’t you? :grin:

Are you sure you did not simply forget your password?

This tends to be the problem when in this situation.

If it truly keyboard configuration on boot, you could Try:

  • Using a separate Parrot Live USB stick (or other Live Linux) to mount the encrypted disk (entering your password from the Live Linux which has the full keyset).

  • Once disk is unlocked you could use chroot for the disk to add new LUKS encryption keys to the disk (such as USB or password). Search for tutorials on mounting encrypted LUKS disks.

There are many tutorials out there on both mounting your encrypted disk manually and using chroot to modify (this saves pages of typing). The Live Linux OS should “see it” when you type lsblk command

Searching for the above bullet points (in many online tutorial) will send you the right direction.

If you apply this advice and get stuck along the way, reply with what you are following and where you are stuck.

I wish there were a simpler answer for you.

I’ve tried live boot twice and reinstalled parrot with no luck if I plug in a usb keyboard it seems to work!? I’m not sure what’s happening now.