Installation fails every time

Briefly describe your issue below:
Hi, I’m trying to install Parrot for a day already. I’ve been trying to use everything from vodka to black magic but unfortunately unsuccessful. I have a new Acer Aspire 5 (i3 10th gen) on which I can’t for some reason switch from UEFI to Legacy.

Please feel free to skip any unimportant steps, I simply tried to provide as much info as I could.

What is the main issue? - My system can’t detect CD-ROM at one of the installation steps. Live boot sends to BusyBox.

It will probably be easier to explain by showing steps I took, so here they are:

  1. I burn ISO into my flash drive (tried both Etcher and Rufus, tried Parrot 4.7 KDE and 4.6 KDE).

  2. Switch off Secure Boot in bios (UEFI stays no matter what).

  3. Boot from a flash drive %D0%91%D0%B5%D0%B7%D1%8B%D0%BC%D1%8F%D0%BD%D0%BD%D1%8B%D0%B9

  4. Get a weird looking blue screen that wasn’t in any installation guide on YouTube 20200115_093656

  5. Press on “Installer” (“GTK Installer” will act the same way).

  6. Second later I get to this command prompt. It stays in this position for around 2 minutes. It is not frozen because I still can type something in case I’m bored 20200115_094138

  7. After 2 minutes it just becomes completely black for 5 minutes, I still can type 20200115_094345

  8. Then it takes me here like that wasn’t enough 20200115_094825

  9. 2 minutes later I can choose language, location and so on.

  10. And then we have this 20200115_095314
    It stays at zero and then says “No common CD-ROM drive was detected. Load CD-ROM drivers from removable media?” and “Manually select a CD-ROM module and device.”.

Is it game over or can I fix it? I specifically bought this laptop to install linux and Parrot seems to have everything I want. And while I could set up pen testing tools on any other distro, I have no idea if I can do the same with security features of Parrot and since I’m new to linux.

1.b) After attempting to live boot, system still let’s me stay in command prompt for some time and then it shows Parrot logo. Before I could get into desktop mode in sends me into BusyBox fd

P.S. Using the virtual box for this ISO works perfectly and without weird looking blue screen.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Parrot 4.7 KDE / Parrot 4.6 KDE
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard and Debian GTK
Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.