Installation Problem on USB Sticks


(sandy) #1

Parrot security 4.3 amd64. Gigabyte z-97 Motherboard, Intel 4690K, only IGP, 16 GB Ram, several ssd and hd
Its running on a multiboot system with mac os x 10.10.5 and windows 7, but I have also tried installation with absolutely no disk attached.
An new Ubuntu installation with the latest amd64 runs well.
I must say, that I am new to Linux at all. But I have some experience with the terminal on os x.


Unfortunately, I have no luck booting an installed parrot.
The Live-USB image works well, but the installation does not boot.
I have tried several methods( standard, Gtk, standard partition, custom etc.) With several usb sticks (Sandisk, transcend) and an USB attached harddisk.

Only two times, I was able to boot:

  1. I have left the live stick inserted. But after 2 boots, this did work no more.
  2. A partionioning with lvm. But after upgrading parrot, the disk was full. And no escape was possible. Also I do not want to use it, because of the bad maintainability of lvm.

All other tries ended in the same issue:

/dev/sdg2 does not exist

I have also tried the grub repair, as described in the gparted help, but without success.

Any hints?


(Matt) #2

Use the newest 4.5 img.

Newer versions are more reliable.


(Kilian) #3

Hi, i have a few question for you so we can maybe find where the issues are.

  1. How did you created your usb live ?

  2. How did you performed the update ? You have to know that “sudo apt upgrade” will break the system

  3. Why choosing ParrotSecurity edition if you are new to linux ? I suggest you download the last home edition, and if you are interested in pentesting you can always install all the tools using a single command: sudo apt update && sudo apt install parrot-tools-full


(sandy) #4

Hi K_L Kilian,

  1. I have created the live usb with dd on os x. Unfortunately the live persistence can’t be configured from here.
  2. The system reminded me, and I pressed the OK button ( as far as I remember…so many fails in the last weeks) Bad idea.
  3. My goal is to keep the system anonymous, as far as possible (on the operating system side). Parrotsec seemed to be a good idea. And you are right, I do not need the pentesting. Is the home edition equal concering this point? And is the installation of the Home edition more unproblematic?

(sandy) #5

Did I mention, that a installation on a virtual machine was not a problem at all?


(Kilian) #6

The creation of the usb stick using dd seems fine to me, what you can try (It wont change much to my opinion) is to use etcher, this is the recommended way of creating usb live of parrot.

For the update story, you shouldn’t have storage issues if we go with a simple install, by the way how much space did you left for parrot ?

No the Security edition isnt more “unproblematic” it is just that home edition is lighter and have no tools but beside that, there is no differences. If you dont need the pentesting i suggest you go with the home edition (this is my daily driver) and as i said you can always go from home to security so no issue here.

Here is what i want you to try if it is okay to you, download parrot home edition and write the iso to the usb key using etcher. Then run a simple install, if you want you can go with /home separated, depend on how much storage you have left for parrot.
If you want to save some space make sure you remove that swap partition, you have 16gb of ram so you dont really need it.

To prepare space for parrot, reduce the partition you want and let the space empty, the parrot installer will find it.

PS: Well the installation in vm shouldnt be an issue.


(Kilian) #7

If you still can’t boot after the install, come back here, grub can be installed manually using the live later. I can help you through the procedure, i have done it a few time already when my grub broke because of windows.


(sandy) #8

Hi,
still no success.
1, I have used edger for creating the live usbs
2. The live-home edition don’ work at all. It does not boot, because it can’t find the folder /live !
And both installers - which are accessible - stop, because they do not find the usb.
(incorrect usb/dbd detected. … contains a system image, which cannot be used for installation.
At this time no other hd were connected ).

And after going back to mac, I see that the stick is damaged. It can only be mounted in an usb 2.0 slot. reformatting does not help.
That is the 3. stick, that has beed destroyed by installing parrot. (sand disk ultra 64GB and others). How is that possible?

  1. And the latest security edition does the same like always. Live ok, installation ok. But no boot.

Grub insall as described in gparted help did not change anything.

Gparted does not want to mount the efi partition of the fresh installated parrot. But the mac does. The content of the partition is:

image

no grub.cfg file! Shouldn’t there be one?


(Kilian) #9

Why didn’t you use etcher as i asked ?
How do you know it doesnt find the /live ? This looks like usb related error so try a new usb key With ETCHER
I dont think your usb stick got destroyed by parrot. If it is too old it just may have done too many writing cycle.
The grub.cfg file is not in the efi partition to my knowledge but in the /boot/grub.

I dont really know how mac handle the boot so i cant help much with that. I am looking for answer and i will get back to you when i have.

But please listen to me and try using etcher this time.

How many system are installed on your machine ? How well does the grub handle boot ? You said OSX is installed so i supposed it is a Mac, is my assumption correct ?


(sandy) #10

just a typo, sorry. I meant etcher not edger. (balenaetcher to be exact, what was the link from the installation guide. And yes, I have used it for both tries. Latest version, fresh install.

And yes, OS X or Mac is runninng, but the hardware is an ordinary PC with a standard Z-97 Gigabyte Motherboard. The Mac system runs as a Hackintosh, you may have heard about that. But this does not matter, because I have stripped all hard disks before installation.

The usb stick was brand new. As the 2 others were. May be these are all from the same bad series.
I tried it again with the home edition, (yes, with etcher!), and was able to install now.
(standard install with separate /home partition, xfs for the system, btrfs for /home, no swap - as suggested by the installer) But the result is the same as with the security edition and the other tries. The boot process stops at the same point like always (after ca 20-30 sec):

Alert! /dev/sdg2 does not exist


(Kilian) #11

This really weird, what about your bios setting ? Is there any safety enabled like secure boot ? These might be problematic. Can you do some description of your gpu and other hardware, what you can also try is when you see the grub try booting with the acpi=off option or the recovery mode when you select advanced option, see if any of these let you boot.


(system990) #12

+1 to K_L on Etcher! Works great in Parrot too.


(system990) #13

Sandy, did you set your BIOS to use Legacy boot instead of UEFI?

Don’t give up on Parrot! I just installed it last night on an HP Stream with no issues. All hardware worked out of the box. Stick with it! It will be worth it.


(Kilian) #14

Why advising Legacy rather than UEFI ? UEFI is a lot less problematic when it comes to boot and boot repair. But yeah i think there must be some setting in his bios that prevent the install from working well.
Like secure boot.


(system990) #15

In the past I’ve had to disable UEFI just to get be able to boot from a thumb drive an install a Linux based OS. I just realized when you asked why that I still do it out of habit. Last night I installed Parrot on an HP Stream and disabled UEFI before installing. I think tonight I’ll enable UEFI and see what happens.

Thanks for questioning why I disable UEFI. I just realized that I’ve been doing it “because I always have” and never checked to see if I can keep UEFI enabled. I’ll let you know what I find out tomorrow.


(system990) #16

I forgot to provide links about UEFI and why people might disable it. I’ll just put one Google search result instead… Why disable UEFI?


(system990) #17

I was looking at another thread and someone named BD1 posted, " I believe that secure boot must be disabled in the bios for most systems…I know that I had to, and have had zero problems after that." so disabling UEFI may be your solution.


(Kilian) #18

Yep, secure boot is an issue for most system Linix, since the only “official” thing to boot is windows…


(system990) #19

Last night I enabled Secure Boot/UEFI and wasn’t able to boot to Parrot. I disabled it and was able to boot into Parrot.

Clarification - What I’m actually doing is enabling support for Legacy Boot which sometimes can be interpreted as disabling secure boot/UEFI.


(Kilian) #20

I got an old Acer that didn’t allow to disable secure boot without disabling uefi, i had to put an admin pass to disble this feature while keeping uefi enabled.