Installation/WiFi problems and solutions

Hello there!
Sorry if my English is poor or a bit unclear, this is my first post (and contribution) to this community forum, I just installed Parrot Home yesterday, and well, the purpose of this post is to talk about some bugs, pains and the solutions that I found in my way installing and using Parrot, and most important, I want to know how to prevent all this errors in the future and help others with this post
PD: I have Win10 in other partition and, naturally, what I wanted is using Parrot and Win10 in dual boot…

So, these are some specifications: my notebook is an Acer TravelMate P253-M, Intel i5 64bit, 8GB RAM, no graphics card, only integrated intel HD4000, Bios in Legacy Mode (yes, it have UEFI too), partitions in MSDOS tables, if you need more technical details, just tell me in the comments.

***THE IMPORTANT PART: let´s talk about the problems I found and the solutions.

1. first bug: horrible graphics on the initial USB boot.
I found an issue related to graphics on the initial boot menu, it looks like some issue with the resolution, maybe just something about my notebook, but I don´t know how to debug this problem (I really want to know). I have taken photos of the screen (see below).
Because of this problem I didn´t use the GTK installer, neither the text installer, instead I had to install the system in live mode that works fine (Until the second bug)…
So, if you have any ideas about why this happens, let me know please.

2. second bug: Grub doesn´t want to install
That´s all, the Debian-installer successfully installed everything, except the Grub, what a pain…
I found that I´m not the only person who experience this error…
So, I solved it using in another USB with Boot-Repair-Disk (this is the download page:, I just followed the steps and problem solved in less than 5 minutes.
Another utility that help me too is Super Grub2 rescue, burn in a USB, it weighs less than 20MB and helps you boot directly in your GNU/Linux distro.
So, if there is someone who knows why this occurs and how to prevent it, let me know please.

3. third bug: (probably the most strange), copying my backup files from the windows partition gave me LIMITED CONNECTIVITY.
Yes, that´s all, after copying 63GB´s of files, I still can connect my notebook to WiFi (I didn´t try Ethernet or Bluetooth), but I just can´t access the web, I´ve tried Ping google but gave me error message (“can´t resolve name temporally” or something like that), after research, I found this post about an older bug in Parrot 3.7:
I´ve tried the two solutions and the second method worked for me…
Why this happens and how to prevent it?

Thanks in advance and greetings!