Internet is not working if Anonsurf is enabled at boot

I have enabled anonsurf at boot with:

sudo anonsurf enable-boot

But the problem I am facing is that the internet is not working… it only works when i stop Anonsurf by

sudo anonsurf stop

And when I start anonsurf by

sudo anonsurf start

It works fine…


ADDITIONAL INFORMATION

OS: Parrot OS 5.0 (LTS) x86_64
Kernel: 5.14.0-9parrot1-amd64
DE: Plasma 5.20.5
Shell: bash 5.1.4

Hi. Try sudo dnstool address 1.1.1.1.

Output:

[!] Address is empty. Skip!
[STATUS]

  • Method: Dynamic
  • Address: Custom

Note: Anonsurf was disabled at that time…

And when enabled:

[!] Address is empty. Skip!
[STATUS] AnonSurf DNS

When anonsurf is enabled, it is better to use localhost rather than 1.1.1.1

It is too hard to say what happened. It is easier for us if you can check if tor was running, iptables rules, dns settings, …

One more thing I noticed :
Anonsurf do not work only if it is enabled at boot. otherwise it works fine when i start it manually…

This is not helpful at all. I tested anonsurf in vm many times with the start at boot and i didn’t see anything wrong. So it is more useful to check everythiing i mentioned about instead of “it doesn’t work”

Okay i reprocedured on my system, with latest anonsurf build: the whole system didn’t have internet connection for 1 minute or so because Tor was connecting to Tor network. After that, everything is perfect

if your problem is different, please provide us more information. at least the details widget in anonsurf-gtk is useful enough for us to guess the problem