Internet only working if anonsurf is running...?

Hello,
Today I started my Laptop, and found that no internet is working with my adapter, I restated but problem was still there. So I connected my device to wired connetction (Ethernet), still problem was there. Just randomly I thought to stop anonsurf typed

sudo anonsurf status

was not running…

then,
sudo anonsurf start

Hi. Try to fix them by typing sudo dnstool address 1.1.1.1.

Hi, i’m new with Parrot Os and almost new with Linux.
I just installed it in Virtual Machine and about this topic i noticed that after the first boot after installation network worked properly, but after i started AnonSurf for the first time, Network works only when AnonSurf is running.

Tried it, but it didn’t solve the problem.

"$sudo dnstool address 1.1.1.1.
[sudo] password di drzaius:
[!] /etc/resolv.conf is not writable. Did you try sudo?
[DNS error] File resolv.conf not found

[*] Applied DNS settings"

Please update anonsurf to 3.3.2. thank you

1 Like

Hi & tnx for the reply, dmknight. 3.3.2 is the version installed (i’ve made an update before starting anonsurf)

“$apt show anonsurf
Package: anonsurf
Version: 3.3.2+parrot0
Priority: optional
Section: net
Maintainer: Parrot Team team@parrotsec.org
Installed-Size: 379 kB”

Internet is working with anonsurf and not when anonsurf is not running weird…

Try sudo dnstool address 139.99.96.146 37.59.40.15 185.121.177.177

I used this (Parrot’s own DNS thingy I cant remember what it’s actually called) to get over our government DNS block, but I don’t have the problem anymore, since they stopped trying to block it.

Mine as the screenshots of Bug_Hunter as result of “sudo dnstool address 1.1.1.1.”.
Also i made a “tour” with the file manager and found that the link for /etc/resolv.conf to /run/resolvconf/resolv.conf is broken (the /run/resolvconf directory actually doesn’t exist).

Try remove anonsurf and install it again

1 Like

It is risky… The only way to use the internet on my machine is onion routing which is performed by anonsurf. Suppose I uninstalled it… and there is no internet to install it again! what would I do then?
The Internet also not working via Ethernet.

Is your Internet working without anonsurf?

I remember it now. It’s Palinuro wanted to change the way system takes DNS address. Look like resolvconf doesn’t run and that’s it.

Then download it, uninstall it and install downloaded files

Did it no use…

Any solution till now?

ah just don’t ask

I recently resolved this very issue by downloading and running resolvconf.

Step 1: sudo apt install resolvconf
Step 2: disable Anonsurf (GUI or sudo anonsurf stop)
Step 3: sudo resolvconf -u
Step 4: reboot your machine if it doesn’t work immediately
Step 5: profit

2 Likes