Issues booting Parrot Ideapad L340

Briefly describe your issue below:
So I bought a fancy new Ideapad, and went ahead and tried to install the newest version of Parrot (Security). The install was successful. When attempting to boot it would display a “amd-vi: unable to write to IOMMU perf counter” followed by a quick ttyl login screen that immediately follows with a blank cursor screen. I tried booting with BIOS in Legacy, disabled secure boot. Same problem. I then tried to boot from the live USB itself and experienced the same problem. I wondered if the issue would continue if I tried installing and running an earlier version of Parrot (4.5). Install suceeded but experienced same message as before followed by a blinking cursor. After much hair pulling I decided to try and boot the live image from USB in “text” mode and what’dya know?! It successfully booted, so I now have a live terminal atleast.
I figured the issue must be with my graphics card, right? I don’t know where to go from here, any help in diagnosing the cause of the issue and mitigating it would be greatly appreciated!

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
4.5 Security MATE
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian GTK
Configured to multiboot with other systems? (yes / no)
no
List your hardware specs to include make, model and firmware (when applicable):
Processor - * 2nd Generation AMD Ryzen™ 3 3200U Processor (2.60GHz, up to 3.50GHz Max Boost, 2 core, 4MB Cache)
Memory - 8 GB DDR4 2400 MHz
Graphics Card - Integrated AMD Radeon™ Vega 3 graphics
f there are any similar issues or solutions, link to them below:**

If there are any error messages or relevant logs, post them below:

UPDATE
I issued a “dmesg | grep IOMMU” command and here were the results:

[1.081253] AMD-Vi: Unable to write to IOMMU perf counter.
[1.084963] AMD-Vi: Found IOMMU at 0000:00:00.2 cap 0x40
[1.356159] AMD IOMMUv2 driver by Joerg Roedel jroedel@suse.de