Issues with GRUB

Unknown Filesystem + GRUB Rescue Issues


Parrot Security 5.0.1

Essentially this is a GRUB issue but i’ve searched online and none of the solutions work. Parrot froze after running a resource heavy program (Godot Engine, don’t think it’s related though). When it froze instead of waiting for the shutdown prompt I just held down the power button and powered off that way. I’m running Parrot on an external Samsung HDD and it’s the only partition on the disk, it was encrypted by Parrot on install and requires a master password in GRUB. So when I rebooted and was prompted, I entered the password and after that I recieved the “Unknown Filesystem” error. I then scoured the internet and did what everyone was telling me which was;

set root=(hd0,msdos1)
set prefix=(hd0,msdos1)/boot/grub
insmod normal

I then recieved:

Filesystem not found
(or does not exist, will have to double check)

I’ve tried this several times on each partition. I’m assuming this (/boot) is where the install for GRUB is by default and cannot work out what it is that’s actually wrong. Does Parrot install it in another directory? I know i’m using the correct partition (but have checked each just to make sure) so the only conclusion I can come to is that it’s not in /boot, or that i’ve broken GRUB somehow and will have to maybe re-install it. My only idea at the moment is installing another distro on the disk and maybe re-installing it that way.

I know this isn’t really a Parrot issue or an Installation issue but I keep getting the same cookie-cutter response everywhere else so any help will be very much appreciated. Will provide more details if needed.

Cheers

If you want to recover grub you can try use tool “boot repair”

You may just follow this guide - https://www.howtogeek.com/114884/how-to-repair-grub2-when-ubuntu-wont-boot/ (spoiler you need live cd)
That worked for me

1 Like

Geezer thanks for replying.

Worked a treat.