Keeps rebooting after "Loading initial ramdisk:

Please complete our guideline for issue report or idea suggestion

If you are having an issue, please follow this

There are many kinds of issues: OS, software, server, … So you must know:

  • Server issues will be fixed after report and we verify the problem. There will be no update patch for you. It is server side.
  • 3rd party software / packages can’t be fixed by us. If we can spot the bug and have the fix, we will create merge request to original source and wait for their official version.
  • Life is hard. For bug/ issue, please make sure your topic is only one. Dont make developers be terrorists.
  • This is a rolling distro. Bugs and issues are expected. We recommend you have basic linux knowledge to deal with your system, so
    Usually we don’t support issues that user faces by using his system in a wrong way. If you are new to Linux, make sure you didn’t make any mistake:
  1. Basic Linux: http://linux-training.be/
  2. How to not break Debian system: https://wiki.debian.org/DontBreakDebian or https://averagelinuxuser.com/how-not-to-break-your-debian-system/
  3. If you are having some questions, your answers might be in here: https://wiki.debian.org/FAQsFromDebianUser
  4. Your issue might be solved before (StackOverflow is a temple), try this: https://www.searchenginejournal.com/search-engines/answering-questions/

1. Your Parrot information

  • OS version: run cat /etc/*release
    ```
    DISTRIB_ID=Parrot
    DISTRIB_RELEASE=4.10
    DISTRIB_CODENAME=rolling
    DISTRIB_DESCRIPTION=“Parrot 4.10”
    PRETTY_NAME=“Parrot GNU/Linux 4.10”
    NAME=“Parrot GNU/Linux”
    ID=parrot
    ID_LIKE=debian
    VERSION=“4.10”
    VERSION_ID=“4.10”
    HOME_URL=“https://www.parrotsec.org/
    SUPPORT_URL=“https://community.parrotsec.org/
    BUG_REPORT_URL=“https://community.parrotsec.org/

     ```
    
  • Kernel version: run uname -a
    ```
    Linux Gryffindor 5.9.0-2parrot1-amd64 #1 SMP Debian 5.8.10-2parrot1 (2020-10-05) x86_64 GNU/Linux

      ```
    

Or if you can’t do it, please tell us ISO version you downloaded.

** ISO information **

Version: 4.10
Desktop Environment: Mate
Edition: Security

2. If you have this problem after fresh installation:

3. If your hardware doesn’t work: wifi doesn’t show, graphic issue:

4. How did you get this error? Are there any steps to procedure it?

This problem is occurring with  5.9.0-2
If I am booting with  5.8.0-2 with advance, bootup goes successful
and there is an another error on grub 
 ```
 error: font character not in ascending order: 1157422139 <= 2456651214
 error: no suitable video mode found
 error: no video mode activate.

After updating through apt-get upgrade i am having another error
awk: error while loading shared libraries: /lib/x86_64-linux-gnu/libreadline.so.8: cannot read file data: Input/output error
/usr/sbin/dkms: line 1315: ((: < 2: syntax error: operand expected (error token is "< 2

5. Error log or screenshot

** Insert error log and screenshot here**

6. If you have any idea or suggestion about this issue please tell us

** Your information **

If you are having suggestion for our OS, please write it bellow

1. Current Parrot version and Parrot version you want it has

2. Its section and how it affects our system

  • Pentesting / Forensic / Malware hunting / Privacy protection / …
  • It is: AppArmor profile / software / system service / kernel module…
  • when user runs this / start that, it can do…

3. Any other information about this idea

You did the upgrade wrong and it crashed your system. The correct way to do is sudo parrot-upgrade.

1 Like

Bullshit. who gave you that idea?

i liked your comment about sudo parrot-upgrade? why come off so offensive? i did nothng wrong

You can use

sudo apt install <package>

but not

sudo apt-get install <package>

@dmknght is a hard working developer of Parrot and I believe the only Parrot developer that assists users on this community.

1 Like

Is a big no-no.

https://docs.parrotlinux.org/faq

1 Like

No need to delete your account here. We all make mistakes. :woozy_face:

Sorry you took offense to Nông’s Bullshit comment. It was probably nothing personal, just upset at wrong info being posted.

1 Like

i do deeply apologize for that and i was honestly trying to state what he told me i have a fully configured system and i wish to better help in the future ill still be here im sorry. i’ve been working hard on my own projects and getting stressed i do apologize though :slight_smile:

Okay,
I will try again with parrot-upgrade

2 Likes

i hope this works sorry for the confusion :slight_smile:

Hey guys,
I did small changes after a lot research and Grub error gone away, don’t know what solved it.
I solved that libreadline8 error by reinstalling this package using gdebi and upgrading dpkg.
I also solved the kernel issue in which 5.9.0-2 kernel was rebooting continuously
So all i did was reinstalling linux-image-5.9.0-2parrot1 and linux headers and reboot and it got fixed

But the last issue remains same, i can access the tty but not GUI,
I found some errors from startx and lightdm.service

startx is saying unable to connext X server: connection refused
and lightdm is not starting

before upgrading my parrot Xserver and Xorg both was running i noticed it in htop
but now these two are not running

GUI is not opening, the cursor keeps blinking non-stop, I tried installing gnome-session but no luck.
How to solve it?

hey how did you update? which commands were used?(:

Before posting this post I used apt-get but after your guidance I used

sudo parrot-upgrade

And what happened after you did sudo parrot-upgrade?

What did you use to burn the iso image on? And what tool was used?

It is not a fresh OS, I am using it since July 2019, nothing changed after upgrading.

try to do a fresh install

did you back up your system to a flash drive before you went playing with stuff?

The thing is, I don’t prefer to reinstall OS since because we don’t have a solution, I would like to troubleshoot it. No matter how much time it takes. I will solve it.
It would be a great help if you can share a solution.

you used apt-get before my command so you may have broken your system pretty badly. i would honestly recommend a fresh install or go to a previous back up. you have to always back up your system

i also recommend doing stuff like this in a virtual machine that way you dont break your actual system since you want to learn how to fix something that is broken i highly recommend breaking your OS inside a virtual box that way you wont have this problem again

apt-get is a big NO! i get it we’ve all messed up i did it once switching here. i use to use Ubuntu so i was use to doing things a little differently and this is why i back up my systems. i learned how apt-get is bad on parrot because i used the command in a virtualbox and saw what it actually did. if you still haven’t fixed it by now id just do a fresh install in my honest opinion

1 Like

Cool, I will try every possible way. I will update you if I caught something.
thank you @Daxter94X