Libreoffice Impress crash when playing videos

Briefly describe your issue below:
I’m trying to play a video with Libreoffice Impress, but every time I open the slide with the video (I tried with both MP4 and OGG), the application crashes without specific errors.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Parrot 4.8 KDE, installed via ISO

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

I havn’t any specific error other than the crash. I tried to install all the gstreamer plugins (good, bad, etc), but nothing has changed. I also tried to run the app without the firejail profile (firejail -noprofile), but again, no luck.
Anyone has any hint for this?

Here is a list of the latest tested formats:


Here is some more detailed information from that page on video formats:

Try converting to MKV or webm.

Let me know how this goes for you and welcome to Parrot’s Forums :slight_smile:

Thanks for the answer, and for the welcome :slightly_smiling_face:

I tried with both webm and mkv, but no luck, I have the crash as soon as I open the slide and the video should start playing.

May be I can give some additional infos to help in identifying the issue?
Thanks again,

Try open it without firejail sandbox

I tried with “firejail --noprofile” and by running it with absolute path (which should run without firejail, correct?). In both the case I have the crash.
May be I should use another way to run it without firejail?

I guessed that was because firejail. Because you tried it so it is a bug of libreoffice and i think you should open an issue for them.

I see…Thanks for the feedback!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.