Libreoffice not starting

Briefly describe your issue below:
I ran full Parrot updates today. No Libreoffice apps will start now. I don’t know if this is due to the updates, or when the problem began.

When I try to start any Libreoffice app, it shows up on the taskbar for a few seconds, and then disappears.

Is there a logfile somewhere that I can pull to investigate?

I have not asked Libreoffice support yet.


What version of Parrot are you running? (include version, edition, and architecture)

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

It sounds to me it may be firejail or apparmor that stops the service from actually executing, try one of those in /var/log under there respective names and post what you find! :smiley:

Have a look through this thread: LibreOffice issue, I need it for work... If its the same issue, then firejail was causing the problem. Have a look and see if any posts in there provide a solution.

1 Like

Thanks, I did a variant of:

Blockquote [KidKlown]
Ok I was able to recreate it. Or at least a problem of the same description.
I deleted the libreoffice configs in /home/user/.config/libreoffice
rm -r ~/.config/libreoffice
Now if i try to open libreoffice it will fail, but if i use sudo it works.
so then use
firejail --noprofile libreoffice
After that i was able to open libreoffice as a standard user again. (Without using firejail --noprofile each time)
So it does look like it is firejail related so if the above doesnt work i suggest looking at custom profiles.

And now it works fine. What I did was, I did the noprofile thing, which showed the splash bar for Libreoffice, but locked the dickens out of the whole computer. I held down the power button and started up again. Then I did sudo libreoffice and it started up. Then libreoffice without sudo and it started, and then started libreoffice from the gui menu and it started fine.



Thank you for this. I have the same issue and this worked.