Loading screen freeze and no GUI


(Rifat Bimbarok) #1

Briefly describe your issue below:
I’ve been trying to install parrot for the last 2 days, and my issue, is that SOMETIMES it gets stuck on the fancy loading screen, and the other times, it gives me a black screen with a prompt, asking me to type my login, when i enter my password, sometimes it freezes, sometimes not.
When it doesn’t freeze at that point, it opens bash, looked for solutions like, startx, just reboot, re-install, install from another .iso.
I tried to apt update & upgrade by connecting to the root, and the upgrade gave me an error telling me i was root and i had to do it with a regular account…
Tried with a regular account after MULTIPLES FREEZES so i had to reboot my laptop again and again til i got to the point where typing apt upgrade was possible aaaaand… freeze.
I reboot one more time, and MAGIC, i can log myself in and use it normally, so i open a terminal, update & upgrade, and guess what? Freeze on the 87% of the upgrade.
I gave up on that one.


What version of Parrot are you running? (include version, edition, and architecture)
Tried 4.5.1 home, 4.5 security, and im downloading 4.5.1 security now

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Both GTK install, and normal install

Configured to multiboot with other systems? (yes / no)
Yep, win10

If there are any error messages or relevant logs, post them below:

Here are my specs :
https://www.msi.com/Laptop/GL62MVR-7RFX/Specification


(Nico Paul) #2

You should head over to the parrot website and read the documentation especially under creating usb stick, pre install prep and installation and upgradeing