locale setting failed

Briefly describe your issue below:
setting locale failed

ifupdown (0.8.34) unstable; urgency=medium

VLAN interfaces that are marked allow-hotplug are now brought up
automatically when the parent interface is hotplugged.

– Guus Sliepen guus@debian.org Fri, 25 May 2018 22:33:22 +0200

libdatetime-format-strptime-perl (1.7600-1) unstable; urgency=medium

From upstream Changes:

[BACKWARDS INCOMPATIBILITIES]

  • The ability to set the pattern, time_zone, and locale via accessor methods
    has been removed. This was deprecated over three years ago in version
    1.60. It also turns out that the setting was actually broken for a long
    time but no one seemed to notice, so I think it’s afe to remove this
    feature.

– gregor herrmann gregoa@debian.org Sat, 09 Feb 2019 22:53:48 +0100
and
sudo dpkg-reconfigure locales
[sudo] password for kokki:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = “en_IN:en”,
LC_ALL = (unset),
LANG = “en_IN.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales (this might take a while)…
en_IN.UTF-8…[error] cannot open locale definition file `hi_IN’: No such file or directory
done
Generation complete.
*** update-locale: Error: invalid locale settings: LANG=en_IN LANGUAGE=“en_IN:en”

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.