Maltego not working

Whenever I am trying to work on Maltego CE it is not responding at all. When tried to open in terminal it is showing the following warnings. Please look at this issue:

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.netbeans.ProxyURLStreamHandlerFactory (file:/home/syam/Downloads/maltego_4.2.16/platform/lib/boot.jar) to field java.net.URL.handler
WARNING: Please consider reporting this to the maintainers of org.netbeans.ProxyURLStreamHandlerFactory
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
java.lang.UnsatisfiedLinkError: no splashscreen in java.library.path: [/usr/java/packages/lib, /usr/lib/x86_64-linux-gnu/jni, /lib/x86_64-linux-gnu, /usr/lib/x86_64-linux-gnu, /usr/lib/jni, /lib, /usr/lib]
at java.base/java.lang.ClassLoader.loadLibrary(ClassLoader.java:2680)
at java.base/java.lang.Runtime.loadLibrary0(Runtime.java:807)
at java.base/java.lang.System.loadLibrary(System.java:1909)
at java.desktop/java.awt.SplashScreen$1.run(SplashScreen.java:134)
at java.desktop/java.awt.SplashScreen$1.run(SplashScreen.java:132)
at java.base/java.security.AccessController.doPrivileged(AccessController.java:312)
at java.desktop/java.awt.SplashScreen.getSplashScreen(SplashScreen.java:131)
at org.netbeans.core.startup.Splash.(Splash.java:122)
at org.netbeans.core.startup.Splash.getInstance(Splash.java:60)
at org.netbeans.core.startup.Main.start(Main.java:271)
at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:98)
at java.base/java.lang.Thread.run(Thread.java:830)

2 Likes

I am also having a similar issue with maltego, not sure if it is the opnjava version that is installed. I have 13. I try running maltego and nothing happens.

Works fine for me both root user and normal user. Make sure you try different java jre or anything related.

it was working fine for me before too, but after some days it stopped working. I had also reinstalled the program and still its shows the same

even with diffrent java versions (8,11,13)

1 Like
  1. Type Maltego in Menue search, 2) select ‘Maltego memory config’ 3) Set path to default-java
  2. Eventually decrease max. memory (had to do down from 32GB to lower value).

(probably the default settings were reactivated, for me worked with this memory config change, also removed/reinstalled Maltego which was probably not required at all ).

1 Like

Thanks, bro this helped out :slightly_smiling_face: :smiling_face_with_three_hearts:. The main problem happening was solved with your help :innocent:, but after updating and upgrading ,maltego goes to 0kali-release than the downloaded version from web, disabling maltego_memory_config from further use


following it then after-screenshot (apt update && apt full-upgrade )
but maltego accessable

Thanks bro :slightly_smiling_face:

1 Like

issue solved

1 Like

Sorry you used version from website then complains about it doesn’t work and ask for help for something unofficial?

1 Like

**SOLVED **
iam also having the same issue with maltego…

  1. go to the official website of maltego…

dont use apt upgrade…

2.install maltego .deb file using your terminal like sudo apt install ./Maltego.v4.2.18.13878.deb

3.type maltego_memory_config

its open a java options window, and please reduce your maximum memmory … i recommended 1350mb

ath replace your path to /usr/lib/jvm/default-java
and simply click ok

  1. lastly type maltego in your terminal

        **good luck and good bye**
1 Like

I followed your instructions and loaded the newer version of Maltego. It worked perfectly.
As reported, when I upgraded my machine, It Downgraded my version of Maltego .

dpkg: warning: downgrading maltego from 4.2.19 to 4.2.17.13809-0kali1

This again did not work. I was using parrot-upgrade, to avoid troubles I have had with full-upgrade not having available servers.

My memory is a little foggy on this, but, Isn’t the full-upgrade the apt version that changes the Operating System back to the standard set by Parrot, and upgrade is the version of apt that keeps the changes made by the user?

If I use upgrade it comments that it is no longer used and changes it to full-upgrade, forcing the failure of the changes that I have made. Yet, this does not always happen. There are several changes that I have made that survive the full-upgrades.

What is going on?

Hi. Not to open a new thread, I have the same issue that Maltego is not opening for me.

When I run from the menu [clicking on icon], I get a right side notification that maltego is starting, get the administrator notification for password, I enter that and then nothing. Not even a splash screen.

I will post a terminal output. I assume there’s missing some java dependencies but want to make sure. Here is the terminal:

┌─[xyz@xxx]─[~]
└──╼ $sudo su
[sudo] password for xyz:
┌─[root@xxx]─[/home/xyz]
└──╼ #maltego
┌─[✗]─[root@xxx]─[/home/xyz]
└──╼ #exit
exit
┌─[✗]─[xyz@xxx]─[~]
└──╼ $maltego
java is /usr/bin/java
found java executable in PATH
pwd: file:/usr/share/maltego/maltego-ui/modules/ext/Java_Config_App.jar
install conf: /usr/share/maltego/etc/maltego.conf
install version: v4.2.17
user conf: /home/xyz/.maltego/v4.2.17/etc/maltego.conf
current java: /usr/lib/jvm/java-13-openjdk-amd64
/usr/lib/jvm: /usr/lib/jvm
/usr/lib/jvm: /usr/lib/jvm/default-java
/usr/lib/jvm: /usr/lib/jvm/java-1.11.0-openjdk-amd64
/usr/lib/jvm: /usr/lib/jvm/java-1.13.0-openjdk-amd64
/usr/lib/jvm: /usr/lib/jvm/java-11-openjdk-amd64
/usr/lib/jvm: /usr/lib/jvm/java-13-openjdk-amd64
/usr/lib/jvm: /usr/lib/jvm/openjdk-11
/usr/lib/jvm: /usr/lib/jvm/java-8-openjdk-amd64
/usr/lib/jvm: /usr/lib/jvm/java-1.8.0-openjdk-amd64
does not exist: /usr/lib/jvm/openjdk-11/bin/java
not jre/jdk: /usr/lib/jvm/openjdk-11
does not exist: /usr/lib/jvm/bin/java
not jre/jdk: /usr/lib/jvm
does not exist: /usr/lib/jvm/java-8-openjdk-amd64/lib
not jre/jdk: /usr/lib/jvm/java-8-openjdk-amd64
does not exist: /usr/lib/jvm/java-1.8.0-openjdk-amd64/lib
not jre/jdk: /usr/lib/jvm/java-1.8.0-openjdk-amd64
/usr/lib/jvm/java-13-openjdk-amd64 VS /usr/lib/jvm/java-1.13.0-openjdk-amd64 (/usr/lib/jvm/java-13-openjdk-amd64/bin/java)
/usr/lib/jvm/java-1.13.0-openjdk-amd64 sym /usr/lib/jvm/java-13-openjdk-amd64
/usr/lib/jvm/java-1.11.0-openjdk-amd64 VS /usr/lib/jvm/java-11-openjdk-amd64 (/usr/lib/jvm/java-11-openjdk-amd64/bin/java)
/usr/lib/jvm/java-1.11.0-openjdk-amd64 sym /usr/lib/jvm/java-11-openjdk-amd64
/usr/lib/jvm/java-1.11.0-openjdk-amd64 VS /usr/lib/jvm/default-java (/usr/lib/jvm/java-11-openjdk-amd64/bin/java)
/usr/lib/jvm/default-java dig /usr/lib/jvm/java-1.11.0-openjdk-amd64
trying path: /usr/lib/jvm/java-1.13.0-openjdk-amd64
canonical: /usr/lib/jvm/java-13-openjdk-amd64
javaHome: /usr/lib/jvm/java-1.13.0-openjdk-amd64
resource:com/paterva/maltego/java/config/jre/TestJDK.class → /tmp/temp1394257904840317252310169988203/TestJDK.class
executing: /usr/lib/jvm/java-13-openjdk-amd64/bin/java -classpath /tmp/temp1394257904840317252310169988203 TestJDK, in: .
result: 0
command execution finished
out: 13.0.5.1, 13.0.5.1+1-Debian-1, Debian, Linux, amd64
runtime: 13.0.5_01 x64 Debian
trying path: /usr/lib/jvm/default-java
canonical: /usr/lib/jvm/java-11-openjdk-amd64
javaHome: /usr/lib/jvm/default-java
executing: /usr/lib/jvm/java-11-openjdk-amd64/bin/java -classpath /tmp/temp1394257904840317252310169988203 TestJDK, in: .
result: 0
command execution finished
out: 11.0.13, 11.0.13+8-post-Debian-1deb11u1, Debian, Linux, amd64
runtime: 11.0.13 x64 Debian
runtimes: 2
selected java: /usr/lib/jvm/java-1.13.0-openjdk-amd64
Detecting appropriate heap size…
resource:com/paterva/maltego/java/config/mem/TestMem.class → /tmp/temp18371511943744321797312974714501/TestMem.class
memOut: 4008378368
pm: 3822/3822
2011…
2916…
3369…
3595…
3708…
3765…
3793…
3807…
selected heap size: 2560
canonical: /usr/lib/jvm/java-13-openjdk-amd64
javaHome: /usr/lib/jvm/java-1.13.0-openjdk-amd64
executing: /usr/lib/jvm/java-13-openjdk-amd64/bin/java -classpath /tmp/temp1394257904840317252310169988203 TestJDK, in: .
result: 0
command execution finished
out: 13.0.5.1, 13.0.5.1+1-Debian-1, Debian, Linux, amd64
┌─[✗]─[xyz@xxx]─[~]
└──╼ $

Update:

Using Synaptic package manager, I went into “Java programming language” section, installed every single version of jdk and jre there is, and now it’s working normally.

However, the package might need updating to a more recent version which is available from the website.

But just know that logging in as root is never preferred, (where you did sudo su)
For the same reason root account is disabled by default.
You have direct perms to burn your system with root, so better just use sudo (only sudo) for getting the perms for what you are doing, but not logging in as root and working there.

Much appreciated your advice, I’m very grateful! :+1::+1::+1::+1: