Mange driver; problem when installing with dkms.

Hello, im trying to install the Mange driver, because rtl8xxxu gives me shitty range and speed.
Here is the github for Mange driver: Mange
Instructions start at the title “Building and installing DKMS”

As you can see it asks you to install DKMS and other required tools with “sudo apt-get install git linux-headers-generic build-essential dkms”. I cant do this because i dont find linux-headers generic(i have everything else installed and updated), so i “apt search linux-headers-generic | grep parrot | grep -v i386” and i dont seem to be missing anything. Only thing that catches my eye is “linux-headers-5.3.0-3parrot3-all-amd64” which does not figure Installed but i dont want to download such a packet ‘just to try’ and brick or introduce noise to my system (correct me if my preocupation is wrong).

So i follow the instructions everything goes butter smooth until sudo dkms install rtl8192eu/1.0, which throws:

Kernel preparation unnecessary for this kernel. Skipping…

Building module:
cleaning build area…
‘make’ all KVER=5.3.0-3parrot3-amd64…
cleaning build area…

DKMS: build completed.

Running module version sanity check.

  • Original module
    • No original module exists within this kernel
  • Installation
    • Installing to /lib/modules/5.3.0-3parrot3-amd64/kernel/drivers/net/wireless//


Backing up initrd.img-5.3.0-3parrot3-amd64 to /boot/initrd.img-5.3.0-3parrot3-amd64.old-dkms
Making new initrd.img-5.3.0-3parrot3-amd64
(If next boot fails, revert to initrd.img-5.3.0-3parrot3-amd64.old-dkms image)
update-initramfs…(bad exit status: 1)

-------- Uninstall Beginning --------
Module: rtl8192eu
Version: 1.0
Kernel: 5.3.0-3parrot3-amd64 (x86_64)

Status: Before uninstall, this module version was ACTIVE on this kernel.


  • Uninstallation
    • Deleting from: /lib/modules/5.3.0-3parrot3-amd64/kernel/drivers/net/wireless//
  • Original module
    • No original module was found for this module on this kernel.
    • Use the dkms install command to reinstall any previous module version.


update-initramfs…(bad exit status: 1)
Warning: There was a problem remaking your initrd. You must manually remake it
before booting into this kernel.

DKMS: uninstall completed.
Error! Problems with mkinitrd detected. Automatically uninstalling this module.
DKMS: Install Failed (mkinitrd problems). Module rolled back to built state.

I have highlighted the errors. The one indicating the trouble seems to be update-initramfs......(bad exit status: 1). I dont know how to proceed, the documentation online doesnt really helped me, i tried using m-a and other tools but with no help.

How do i proceed?
Thanks in advance, i’ll leave some info below, specially the model of the USB wifi antenna.

What version of Parrot are you running?
Linux parrot 5.3.0-3parrot3-amd64 #1 SMP Parrot 5.3.9-3parrot3 (2019-11-23) x86_64 GNU/Linux KDE.

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard Security KDE.

Configured to multiboot with other systems?
YES, Windows 10 1909 64bits.

List your networking hardware (make, model, firmware version):
TP-Link TL WN823N V2 USB Wireless Antenna. Chipset: RTL8192EU.
Only wireless device. Its a desktop PC so i have one Ethernet port, nothing else.

How full is your /boot?

sudo apt autoremove -y && sudo apt autoclean

and reboot and then try again.

The kernel-headers must match the uses kernel!
see HERE

1 Like

and i think we do not support i386

Thanks for your answer.

I have 90mb free on /boot, i think its enough.

I tried the apt autoremove and autoclean, then rebooted and did the process of dkms installation again, but no differences at all.

I also ran sudo apt-get install linux-headers-$(uname -r) build-essential dkms git and i have all in order and updated.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.