metasploit error

try upgrading metasploit by

sudo apt update && sudo apt install metasploit