MITMF not working on Parrot

I noticed that MITMF on Parrot OS is from the Parrot repository, and when running it, i (and everyone else) get the error

Traceback (most recent call last):
File “./”, line 36, in
from plugins import *
File “/usr/share/mitmf/plugins/”, line 72, in
from libs.bdfactory import pebin
ImportError: No module named bdfactory

The installation description of MITMF says that after pulling the repository, you also need to get the submodules, and after trying it manually it does work. git submodule init && git submodule update --recursive

MITMF does not work since 3.10 i think, if you could add the lines to your script for your next update, would be greatly appreciated.


rm -f /usr/share/mitmf/plugins/

seems to fix this issue, however the HTML5 screenshot plugin does not work correclty. It does however work correctly in BlackArch.


I’m relatively new to pentesting, so if it’s a stupid question I’m sorry about that.

Is this a problem with MITMF, or parrot? And is there anyway to resolve it (besides using BlackArc)? (‘it’ being the screenshot function)

Parrot problem, but the clone the github version, follow the install instruction, and it will work.

So, I cloned this github version, and tried to follow the installation instructions here in this wiki

However I get stuck at:

Install virtualenvwrapper:

pip install virtualenvwrapper

Edit your .bashrc or .zshrc file to source the script:

source /usr/bin/

The location of this script may vary depending on your Linux distro

Restart your terminal or run:

source /usr/bin/

Create your virtualenv:

mkvirtualenv MITMf -p /usr/bin/python2.7

Any thoughts/help?

Just clone

cd MITMf && git submodule init && git submodule update --recursive

pip install -r requirements.txt

Then should work.

Thanks for your help, and patience.

I’ve been at it for the past few hours…
I’m stuck with this error now, any ideas? (Error starting SMB server: [Errno 98] Address already in use

I’ve managed to resolve it.
Restored a snap shot, purged mitmf, then cloned from github etc… nd it now works

Sorry for the late reply! I never seen this bug, but good work ! :slight_smile:

@RobRizzoSJ iget the same error .could you please explain me the steps you did to fix it ? Also after i exit the MITMF i can not resolve any website till i reboot the computer . Thx in advance

if the port is already in use it means that the smb service is already started

if mitmf needs to start its own smb server, then just make sure to disable samba, smbd, nmbd and any other samba-related service