Modprobe.d error on boot

Briefly describe your issue below:

After the latest update using “sudo parrot-upgrade” I now have an error showing during post on boot

libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/blacklist-libnfc.conf line 3: ignoring

Thinking that perhaps initramf was stale and not refreshed after update and reboot, I ran
sudo update-initramfs -u in an attempt to force an update, the result was:

libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/blacklist-libnfc.conf line 3: ignoring bad line starting with 'blacklist-libnfc.conf' 

So I checked the contents of blacklist-libnfc.conf to try and see what the issue was and found:

1 blacklist nfc
2 blacklist pn533
3 blacklist-libnfc.conf

So it kind of looks like a loop causing the error…any ideas?

What version of Parrot are you running?
ParrotSec 4.7
KDE Plasma 5.14.5
KDE Framework Version 5.54.0
QT Version 5.11.3

Linux parrot 4.19.37-parrot1-amd64 #1 SMP Parrot 4.19.37-5parrot1 (2019-06-22) x86_64 GNU/Linux running KDE Plasma

What method did you use to install Parrot?
update from prior version and changed over to “rolling release”

Configured to multiboot with other systems? (yes / no) No

If there are any similar issues or solutions, link to them below: None found

If there are any error messages or relevant logs, post them below:

1 Like

anyone have any ideas on this??

Still looking for any feedback on this. Can I just delete that line from the blacklist-libnfc.conf file?

Just ran the latest updates as of today.

libkmod: ERROR …/libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/blacklist-libnfc.conf line 3: ignoring bad line starting with ‘blacklist-libnfc.conf’

Did you ever find a solution? I am having this exact same issue. Parrot KDE was running fine until I couldn’t update or upgrade anything! Now I’m not able to install packages. The same error message shows up every time.

It’d be great if one of the mods saw this and gave some insight. Patiently waiting until then :slight_smile:

I have not had any solution provided…if I get some spare time, I might have to dig into it myself.

Hi. I personally don’t have this line at all. Have you tried upgrading again? Please describe the steps you took for us to reproduce the bug or just delete that line and run parrot-upgrade again.

yes, I have since repeatedly run sudo parrot-upgrade and the sytem has run through the update & upgrade process without a change in the above error.

Google search had several similar finds, the best seemed to be found on
this Ubuntu board
and on Stack Exchange the later is where I got the

"For a Debian-based distribution, this is handled by update-initramfs from the initramfs-tools package, which is mostly a bunch of shell scripts that eventually call cpio . The typical update command looks like this:

sudo update-initramfs -u

I have since removed line 3 and again attempted to update, but still getting the same error even after a restart…still digging into it.

That is weird, do you face the same error? Because if you’ve deleted it you shouldn’t really get any errors.

Just a wild, uneducated guess.

Have you tried to remove the “-” between blacklist and libnfc ? the command is blacklist and it should blacklist the object libnfc.conf. with “-” system tries to execute a command that doesn’t exist.

I am not sure if there is any module with a .conf extension.

from what I have read, it might have something to do with the initial RAM filesystem for all installed kernels. Each installed kernel has its own associated initramfs. "The initial RAM filesystem is (re)built under some circumstances, such as when a new kernel is installed and as a result of some driver installations and some configuration changes. " – see the Ubuntu board here

It appears that even though the system has since been shut down and restarted several times, and the command update-initramfs -k all -c was used to rebuild ( -c ) the initial RAM filesystem for all installed kernels ( -k all ).

Even though the line is in fact no longer present in the blacklist-libnfc.conf file, the error message is still persistant…interesting.

This is very interesting, is the error the same? You should look over for that line in other blacklist files I guess.


grep -Rls "blacklist-libnfc.conf" /etc/modprobe.d/

if it doesn’t show anything try

grep -Rls "blacklist-libnfc.conf" /lib/modprobe.d/

yes, still gettin the same error message on boot and there is nothing similar in any other blacklist files.

neither of the grep searchs result in any reply showing

The upgrade I performed today has apparently flushed the bug out of the machine…no more error on boot and all looks good now.

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.