My Parrot is not logging in

Briefly describe your issue below:

What version of Parrot are you running? (include version (e.g. 4.7), Linux Parrot 5.2.0-2parrot1-amd64 #1 SMP Debian 5.2.9-2parrot1 (2019-08-25) x86_64

What method did you use to install Parrot? (Debian Standard )

Configured to multiboot with other systems? (no)

My Parrot system refuse booting into Gui but booting into tty1 if I force it to boot into tty7 it keeps showing a blinking cursor I have tried startx still not working

when you say “blinking cursor” are you saying you at no point see a login prompt?

Is it completely black screen with simple blinking cursor top left?

Please include more details… like is this directly after install, or for example, after upgrade? After changing bios? Details. Please be as clear as possible

The above doesn’t give enough details.

I assume if you tried startx this means you were able to get a shell? Is Grub loading?

I will let you fill in the important details and check back later.

Note: Ethernet required.
When you tty1 terminal appears, at first you have to login with your user account. After login in successfully, check the parrot.list file and make sure the repositories are set correctly. And after that, do a parrot-upgrade.
For that just type:

sudo parrot-upgrade

Well, this works most of the time, if you haven’t messed up with DDEs or Xorg.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.