My problem with cuda/nvidia-driver

Release ParrotOS 4.5
Intel® Core™ i5 3317U
Intel® HD Graphics 4000
NVIDIA® GeForce® GT 620M

After a apt-get full-upgrade stopped working hascat.

After the upgrade, the driver is installed from nvidia 410. *, everything worked before with driver 390. * and nvidia-cuda-toolkit.
But even if you install the old driver 390. *, and then the nvidia-cuda-toolkit, then the dependencies and other things are set for the driver 410. * and leads to a conflict …
Why is driver 410. * installed if the video adapter is not in the supported lists?
How can I install tvidia-cuda-toolkit for driver 390. * with which everything worked?

apt install -y ocl-icd-libopencl1 nvidia-driver nvidia-cuda-toolkit

after this command, to verify;

hashcat -I

for benchmark test:

hashcat -b

In the event setup isn’t going as planned, please write the output of command.

you can read about what upgrade commands not to use and the correct ones Here

I broke everything, now I can not install: nvidia-driver & nvidia-cuda-toolkit
Errors occurred while processing the following packages:
** glx-alternative-nvidia**
** nvidia-alternative**
** libnvidia-ml1:amd64**
** libgl1-nvidia-glx:amd64**
** libegl1-nvidia:amd64**
** libcuda1:amd64**
** libnvidia-cfg1:amd64**
** nvidia-opencl-icd:amd64**
** libglx-nvidia0:amd64**
** nvidia-kernel-support**
** xserver-xorg-video-nvidia**
** nvidia-vdpau-driver:amd64**
** bumblebee-nvidia**
** nvidia-kernel-dkms**
** libgles-nvidia1:amd64**
** libegl-nvidia0:amd64**
** nvidia-settings**
** nvidia-driver-libs-nonglvnd:amd64**
** nvidia-smi**
** libgles-nvidia2:amd64**
** nvidia-driver**
** nvidia-driver-bin**
** nvidia-nonglvnd-vulkan-icd:amd64**
** libnvcuvid1:amd64**
** nvidia-persistenced**
** libcuinj64-9.2:amd64**
** nvidia-cuda-dev**
** nvidia-egl-icd:amd64**
** nvidia-profiler**
** nvidia-cuda-toolkit**
** nvidia-visual-profiler**
Configuring sandbox profiles…
Sandbox profiles updated!
E: Sub-process /usr/bin/dpkg returned an error code (1)

I made a mistake, I decided that the update will not hurt, now everything has only become worse.

Now i have:
dpkg-divert: ошибка: переименование вызовет перезапись «/usr/lib/mesa-diverted/x86_64-linux-gnu/» другим файлом «/usr/lib/x86_64-linux-gnu/», что не разрешено

#find /usr -name /usr/lib/mesa-diverted/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/primus/ /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/nvidia/current/

dpkg-divert --divert /usr/lib/mesa-diverted/x86_64-linux-gnu/ --rename /usr/lib/x86_64-linux-gnu/ Оставляется «локальное отклонение /usr/lib/x86_64-linux-gnu/ в /usr/lib/mesa-diverted/x86_64-linux-gnu/»
How fix it?

It’s probably best to reinstall however i don’t read Russian so idk what it is really saying which is why i am saying it’s easier to reinstall most likely. remember not to add repos and remember use parrot-upgrade as your command

Run next commands to remove package dependencies:

sudo dpkg-divert --package nvidia* --remove /usr/lib/x86_64-linux-gnu/ &&
sudo dpkg-divert --package nvidia* --remove /usr/lib/x86_64-linux-gnu/ &&
sudo dpkg-divert --package nvidia-* --remove /usr/lib/x86_64-linux-gnu/ &&
sudo dpkg-divert --package nvidia-* --remove /usr/lib/x86_64-linux-gnu/ &&
sudo apt install --fix-broken

Now try to reinstall graphics drivers with our tutorial.

I deployed a clean system on a similar hardware and executed the commands:
sudo apt update
sudo parrot-upgrade
Next step (Step 3):
Next step: install nvidia-cuda-toolkit
And now i have:


The driver also does not want to work…

everything should be run with optirun prefix. I.e:
optirun nvidia-smi.

Pleae read docs before asking for help.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.