Need help to run snap program

Briefly describe your issue below:
I have installed gnucash using “sudo snap install gnucash-jz.” I now try to run it by "snap run gnucash-jz but get the following error, error: cannot find app “gnucash-jz” in “gnucash-jz”.
I have never used snap before so could use some help here.


What version of Parrot are you running? (include version, edition, and architecture)
Parrot Home 4.3
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Don’t remember
Configured to multiboot with other systems? (yes / no)
No
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
error: cannot find app “gnucash-jz” in “gnucash-jz”

You can just run it using: /snap/bin/gnucash-jz.gnucash
But… it will tell you to install some gnome stuff?

Alternatively, it will run if you use: /snap/gnucash-jz/current/bin/gnucash

Thanks for the help but still having issues. Tried “/snap/gnucash-jz/current/bin/gnucash” got error “/snap/gnucash-jz/current/bin/gnucash: error while loading shared libraries: libwebkitgtk-1.0.so.0: cannot open shared object file: No such file or directory”
Next I tried “/snap/bin/gnucash-jz.gnucash” and it told me about GNOME stuff I had to load and I did that and it worked, but only once and now I can’t do it again.

Give this a try sudo apt-get install libwebkitgtk-1.0-0

Tried but got error

Reading package lists… Done
Building dependency tree
Reading state information… Done
Package libwebkitgtk-1.0-0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘libwebkitgtk-1.0-0’ has no installation candidate

try to exec /snap/bin/gnucash-jz instead

Tried to run but no good.

$snap run /snap/bin/gnucash-jz
error: cannot find current revision for snap /snap/bin/gnucash-jz: readlink /snap/snap/bin/gnucash-jz/current: no such file or directory

I got it to run again by typing as follows but with errors but it seamed to work.

snap run gnucash-jz.gnucash
ln: failed to create symbolic link ‘/home/don/snap/gnucash-jz/25/.config/gtk-2.0/gtkfilechooser.ini’: File exists

This is a development version. It may or may not work.
Report bugs and other problems to gnucash-devel@gnucash.org
You can also lookup and file bug reports at http://bugzilla.gnome.org
To find the last stable version, please refer to http://www.gnucash.org
Fontconfig warning: line 5: unknown element “its:rules”
Fontconfig warning: line 6: unknown element “its:translateRule”
Fontconfig error: line 6: invalid attribute ‘translate’
Fontconfig error: line 6: invalid attribute ‘selector’
Fontconfig error: line 7: invalid attribute ‘xmlns:its’
Fontconfig error: line 7: invalid attribute ‘version’
Fontconfig warning: line 9: unknown element “description”
Fontconfig error: Cannot load default config file