Network nterface name issue

Issue below:*

  • My network interfaces
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether e0:db:55:c3:c4:61 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether f8:2f:a8:c9:17:33 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute wlan0
       valid_lft 5292sec preferred_lft 5292sec
    inet6 fe80::9bfa:3023:e1e5:4c7f/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
  • If i run ifdown / ifup command, it shows error interface name not found
└──╼ $sudo ifdown wlan0
ifdown: unknown interface wlan0
  • In native Debian, Interfaces will be named like enp9s0, wlp7s0 as I remember, and ifup / ifdown commands work fine. So I guess there is a small bug in Parrot system.
    p/s: ifup and ifdown solve issues when restart network-manager service can’t solve.

What version of Parrot are you running? (include version, edition, and architecture)
Parrot Security OS 4.5 amd64, updated 28/1/2019

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian GTK
Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Please visit that page and read:

ifup, ifdown worked for me in Debian, for wireless interface. And eth0 is having this problem on Parrot OS.
p/s: i think you misunderstood, this topic is about interface name problem, not about wireless not working

Please replase ‘wlan0’ with ’ wlp7s0’, and follow that page suggestions to rise up your wifi.
Same you have to do for ‘eth0’.

You can use ifquery --list to list all the interfaces you can manipulate with ifup or ifdown. I would guess ‘wlan0’ isnt listed. ‘ifup’ and ‘ifdown’ probably need some additional configuration to work.

What i would recommend, is you use sudo ifconfig wlan0 down and sudo ifconfig wlan0 up instead. It should work just the same.

I just checked my machine and this is a fairly easy fix, if you really want or need to use ‘ifup’ and ‘ifdown’.

Its because ‘/etc/network/interfaces’ hasnt been populated. Simply add:

auto wlan0
iface wlan0 inet dhcp

at the bottom of the file.

Then when you use ifquery --list you will see it listed. You can now use ‘ifup’ and ‘ifdown’, although you may need to use the ‘–force’ option the first time, as it wont know what state the interface is in.

I think this is exactly the reason. Currently my ifquery --list is having lo interface only and /etc/network/interfaces is having

# The loopback network interface
auto lo
iface lo inet loopback

so, it could be other interfaces haven’t defined yet.