Nginx broken. Only shows apache2 page

Briefly describe your issue below:
For some unknown reason, it’s only showing the apache default page the index-debian.html I have configured nginx and it’s setup exactly like how I have it on my chromebook(running ubuntu lts), and my old laptop(running debian stable).

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Security amd64
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:
nope i’ve tried it all.
If there are any error messages or relevant logs, post them below:
There is my nginx sites-available/default configuration file.

I don’t know if this is something to do with parrot or what’s going on. A reboot doesn’t fix the issue though and I have checked and confirmed that apache is not running. I don’t know what the hell is going on here. The directory has permissions of read for others on it.

I sent a message to mods. I was stupid and forgot to clear browser cache that was the sole issue. This topic is now moot.

The default root folder for nginx is /var/www/html, its also the same for apache2, thats why it shows the apache default page. You could try changing /var/www/html/index.html, just to confim that is the root of the webserver.

Your config looks correct assuming your my_site directory exists ect… So is there a working symbolic link from the sites-enabled directory?

You could also try using the conf.d/ directory instead.

service nginx status to check nginx service status
service apache2 status -> the same for apache2
nmap -p 80 -sV to make sure you are running nginx (interface)

As stated in the edited front post, I was stupid and forgot about clearing the browser cache. I verified that the site was working(by running curl on it) and it worked just fine. Cleared the browser cache for the last 1hr and it started showing the correct page. So it was a case of surpreme stupidity on my part. This post can be now marked as deleted or whatever since I am so stupid to not remember that the browser will cache the location and may not invalidate the cache when going back to it again.

Ahhh lol at least it was an easy one in the end.

Btw you can use ctrl + f5 to refresh/reload the page from server instead of cache.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.