No internet after update

Briefly describe your issue below:
Imternet via cable and wifi used to work fine in all situations anonsurf on or off. Then I updated using the info on this site and it stopped working.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
V 4.8 Kernal 5.4.0 64 bit Security Mate
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)

List your networking hardware (make, model, firmware version):
Compal Broadband Networks INC. I.S.P. branded

If there are any similar issues or solutions, link to them below:
I have reinstalled it twice after the update and the last time, the one I have now, the internet worked for a while but only when in anonsurf mode and then even that stopped. I tried turning the firewall off and on trying it but still no internet. Firewall in standard home settings.
myip brings up a blank space where there should be an I.P. address.
Another stange thing after the update was that the favourites in Firefox were duplicated with more links listed in each of the newer stared favourites on the Bookmarks bar. I deleted the older ones.

If there are any error messages or relevant logs, post them below:

I suppose I could reinstal but not update as it worked fine before as a fresh install. Would this be a problem with security or something?

1 Like

how do you upgrade your system?
with apt upgrade?

sudo parrot-upgrade
Then twice, after each reinstall, I clicked on the udate box that appears.
I am using a DELL Latitude E6410 i5 m560, 5.7 GiB RAM, if that makes any difference.

Hey Andrew, full disclosure I’m fairly new with this OS, but I’ve had success installing it on multiple machines. Here are a couple recommendations:
To update / upgrade, run the following:
sudo apt update && sudo apt upgrade -y

I believe “parrot-upgrade” is to upgrade the OS itself to the latest version, but I could be wrong.

Regardless, I’ve always relied on sudo apt update and sudo apt upgrade for managing my Debian-based linux distros.

I also ran into some driver issues when I first experimented with Parrot (and other linux distros). I am running different wireless firmware, but the process should be the same. You’ll want to find the linux-compatible drivers from your vendor’s website and get those in the appropriate directory. During installation, it may have already downloaded those proprietary drivers for you.

I would try using the update / upgrade commands I listed above rather than doing the parrot-upgrade command you ran.

please dont do a

apt upgrade

parrot is a rolling release distro and that will brake your system!!!

Really? Kali is a rolling system and accepts the same command. I haven’t had any issues with Parrot running this command. I’m not saying you are incorrect, just curious what would break here?

The documentation specifies to not run any apt-get commands.

1 Like

Thanks Zach that seems to have worked. :+1:
I did it last night and it is still connecting to the internet today with anonsurf on or off. I hope it
Although I will have to start another thread as I have a question about PostgreSQL, V11 or 12?

Awesome! Yes, I would recommend starting a separate thread.

Upon doing further review, Parrot documentation recommends running apt full-upgrade by default. This will install and remove dependencies automatically, which should help with stability. I’m guessing parrot-upgrade is an alias command to run apt update && apt full-upgrade.

1 Like

Maybe it was corrupted during DL the other 2 times I did it? Those times I used exactly what is written on this site:

sudo parrot-upgrade

The internet has stopped working again. I know what the problem is connected with, it is using the icon in:
applications, privacy, anonsurf, start. After using this the internet would not connect. Before using this icon to launch anonsurf I used sudo anonsurf start and it worked fine.
I got a message that the ATK bridge wasn’t working when I first used the icon to start it so I used:
sudo apt install libatk-adaptor and it installed it, but it still will not connect. I have looked on the web and there seems to be a problem when starting it not using the comand line sudo anonsurf start. So I hope someone knows what has broken and how to fix it as I do not want to reinstall and update it yet again.

I also clicked on TOR browser and that was installed before I lost internet.
1 Like

I have reinstalled, again, and will not be using TOR again. I will also be using the command line sudo anonserf etc and not the icon to launch it. I think it may be TOR that is the problem.

1 Like

ppl have to learn how to find out connection problms with ip ad sh, ping and nslookup!

do i have a valid IP?

ip ad sh

ping out with ip possible?


ping out with name possible?



sudo anonsurf stop

fixes problems in nameresolution.
learn to check some basics guys and working with you system will be easier and easier. :wink:

1 Like

I tried the stop option and other combinations of commads but nothing worked. I replicated it by clicking on TOR which caused it to be installed. After which the problems began. It may have been also linked to using the icon to lauch it, anonsurf, as I read on the internet that it can cause problems if you launch it like that.
The internet is working, at the moment, so I am watching some Null Bytes vids to see what I can do with this software. I am in a city in lockdown mode(only food shops open and banks, of course) so I need something interesting to passs the time.

1 Like

I resolve the bug by doing this troubleshoot.

The problem

  1. If you turn on AnonSurf then you turn of your PC, without turning of the AnonSurf this will be the bug or the problem.

The Solution

  1. So please turn of the AnonSurf before you turn of your PC.
    Simple this step can solve the problem easily.

sudo anonsurf stop

Thank you all.
Love you Parrot.



This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.