No Sound in my New Laptop!!

Hey There !
I am not new to parrot os but facing lots of difficulties.
Got a new laptop with default windows installed on it everything was working fine. I installed parrot with a USB.
The problem is my microphone and speakers are not working

I am using :
OS: Parrot OS 5.0 (LTS) x86_64
Host: HP ProBook 450 G8 Notebook PC
Kernel: 5.14.0-9parrot1-amd64
CPU: 11th Gen Intel i7-1165G7 (8) @ 4.700GHz
GPU: Intel TigerLake GT2 [Iris Xe Graphics]
DE: Plasma 5.20.5

/etc/modprobe.d/alsa-base.conf was empty and no sound and microphone were even detected !!

Then I edited it to

options snd-hda-intel dmic_detect=0
options snd-hda-intel model=laptop-amic enable=yes

happily sound was enabled and both speaker and microphone were detected


Hoping for a solution from your side

Hi. The fact that it is not recording anything could be a problem with the software you are using to record your voice. See the settings of that software and verify that the microphone is the input device.

No sir! I tried recording with whatsapp web , online mictest, gnome sound recorder and even with camera which is capturing the video but not the audio

From the settings, however, the test does not work? Have you checked that the microphone volume is at maximum? Check again with alsamixer. If it is detected then it must work.

I don’t understand this diagram can you help me with this??

sudo alsamixer

@danterolle Any other solutions Please dont leave this issue unsolved??

F1 for help.

And is this Bluetooth? If yes it might have something with kernel if not working at all, but if speaker works but not mic, then change the audio profile from high fedility to another (high output quality to low quality), with low quality you can you both mic and speaker simultaneously.

You must know that this problem is not strictly about Parrot, you would also find it in other distros, so I ask you to have more patience.

Now, as you can see, the microphone does not receive any input, so either some audio driver is missing (but I doubt), or it may be necessary to check the flags of alsa-base.conf, but it is a known problem from what I have read online, so you have to try the various solutions.

No, it isn’t. The microphone is recognized, only for some reason it does not receive, but there are a multitude of solutions, he must try more solutions, it could also try the sof drivers, but I don’t know if they can help it.

@Hashir_Siddiqui since we are including all possible options, check if the microphone is not disabled at the hardware level (there is a keyboard button with the microphone icon, press the combination fn + f8).

Microphone was working fine some days ago but now not working
and also not muted from the laptop or from the bios settings !!???
and how do I check flags os alsa-base.conf ???

But it was working 2 days ago!
I think after an update all this happened !??

Note: The microphone is not muted in the keyboard nor in the bios…

@Th3Director Sir! Bluetooth is working well and good

Any one help please

well if anybody knows, you will surely be answered.
Or if unsuccessful you might give a try for our telegram community which is kinda more active sometimes -

I am already in …

If your issue has not solved yet then u can try this.

sudo geany /etc/modprobe.d/alsa-base.config

Then type following things and save.

options snd-hda-Intel dmic_detect=0
options snd-hda-Intel model=laptop-amic enable=yes

I hope this can help.

Sadly, it is still not working even after reboot…

In path /etc/modprobe.d/alsa-base.conf I wrote the same lines with intel’s ‘i’ in lowercase… after which speaker worked and also the mic but after an update the speaker is working but the mic is not…

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.